No response after +++

Hello!!

I’m able to communicate with the XBEE module using the X-CTU and Hyper Terminal applications so I know the hardware is working fine.

I’m busy developing software (WIN32) to talk to the module and have run into the following problem.

I’m able to open a file handle using the CreateFile API. To enter command mode i send ‘+++’ but get no response from the module. I know the module receives the string because the green LED flashes when data arrives. Shortly after that the orange LED should flash to indicate that data has been sent ‘out’, but this does not happen.

The write command looks as follows:

*** MASM 32

szPlus db ‘+++’,0 ; command mode string
hConn dword ? ; connection / file handle
bytes dword ? ; received bytes counter

invoke WriteFile, hConn, addr szPlus, sizeof szPlus, addr bytes, NULL


In your program, keep in mind there’s a guard time necessary before and after the +++ (GT parameter value). You’ll likely need to add a pause or delay in other words.

I wait 1 second before I issue the ‘+++’ string. I’ve also tried 2 and 3 seconds. I’ve also tried sending in three ‘+’ with a 250ms delay between each write. I’ve also tried sending in 2B hex instead of ASCII.

I’ve configured the communication settings as follows:

BaudRate, 9600
ByteSize, 8
Parity, 0
StopBits, 1
Com Port, \.\COM14

Is there anything else I can look at or try perhaps?

I’ve managed to get comms going…

I changed the BaudRate setting to 3.