XBee 2 Configuration

I have the XBee 2 and used the development kit to get things started. Configuring the XBee’s and such using the master module and the X-CTU software. However, now what I thought would be the simple mater of programming new XBee modules on the target board using its serial port and AT commands doesn’t seem to be working. Send +++CR at the default baud rate and the XBee doesn’t go into command mode. Is there something else that needs to be done to the hardware to make it accept commands? What am I missing here.

Thanks for any help

oops, there is no cr after the +++ however, I’m trying delays before and after the +++ string… I’ll see how that turns out


Is this an XBee OEM module, or did it come from one of the adapters in a Starter Kit? If the radio came from an adapter, which one?

Hello Ijlong45,

I’m newbie in XBee material, but I wish that my instruction below can solve your problem.

If you want enter into AT command mode, you just go to Terminal tab on X-CTU software. And then you have to type 3 plus characters –> +++ in 1 second, ok, remember, just 1 (one) second and does not need excecutor like enter button, so you just type 3 plus character and wait for respond, OK or ERROR.
And be note –> before and after type the 3 plus characters, make it sure there are no character typed in the terminal window, ok.
And if you would like to exit from AT Command mode, you can type ATCN and press your enter button.

I wish it can help you.

Try it.

the module is from the kit and the usb interface is from the kit. We have some oem modules that the target hw cpu will need to program… change baud exc

I currently using a module that I have working and as a simple first test I’m just trying to change the baud rate back to 9600… but the system ignores the +++ maybe because of the timing???


The command you’ll want to use for that is ATBD3

yes that would be correct if I could get +++ to work


What type of firmware did you load in the module? Is it an API or AT profile?

If for some reason the “+++” is not entering you into CMD mode there is a method to FORCE entry into CMD mode (assuming you have AT firmware and not API firmware). If you go to the ‘Terminal Window’ of X-CTU and check the ‘Break’ box at the top of the screen then hit the modules /RESET button the module should return “OK” (you must uncheck ‘Break’ before beginning to enter commands). This is because if the /CONFIG line is held LOW at power up the module will start in CMD mode at 9600 8N1. Hope this helps.