Package Manager doesn't find updates

I’ve just uninstalled my Digi ESP Net+O/S, patched to 7.4.2, installation, and reinstalled from the 7.4.0 CD, with a view to updating it to 7.4.2.

However the Package Manager doesn’t find the updates - it found one update to the Package Manager itself, and that was all. Its simply not finding or listing the updates.

Any ideas on how to provoke some updates?

I have a similar problem.

When I installed from 7.4.1 disk the updates seemed to work and the package manager shows a total of 11 updates.

Looking at the web site today it shows updates as being released on 04/14/2009 but package manager does not seem to have tried to get these yet.

I do control my NetOS directory with Visual Source Safe as I like to see what is being updated in detail so the directory is currently read-only, but I thought that the package manager would download the updates and I would then manually run the installs

You’re doing better than me!

Having applied all the patches fairly promptly from 7.4.0 through to 7.4.2 (with 7.4.2 being available on 14/4/09, as you say), I was seeing a total of 17 updates applied. I was having some problems with applications compiled under 7.4.2 (and that was after I had updated my source to reflect the changes - I hope). So I deleted and reinstalled - and have now gone back 16 steps!

Looks as if the package manager can’t cope with a major incremental change, or something.

If all else fails, I think I’ve still got at least most of the updates, but that’s not a nice way to do it.

There was a critical flaw with the 7.4 SP2 patch that caused Digi to pull it down temporairly. If you downloaded it, you need to add a -clean to your ESP shortcut to get code to build properly (it builds, but does not run properly).


  • Close the ESP
  • modify the ESP shortcut to say something like: C:\Program Files\Digi\Digi ESP\digiesp.exe –clean
  • start up the ESP

After starting the ESP once, you can remove the -clean from the shortcut.

I should also add that for any projects built in 7.4.2, you need to do a Project -> Clean after the above fix to get them to build/run properly.

> There was a critical flaw with the 7.4 SP2 patch that
> caused Digi to pull it down temporairly. If you
> downloaded it, you need to add a -clean to your ESP
> shortcut to get code to build properly (it builds,
> but does not run properly).
This at least explains why I’ve ended up with a ME9210 which may be wrecked!
But it doesn’t explain why I can’t see any patches at all, other than an update to Package Manager itself.

Is the 7.4.2 update now available again?

I tried this this morning, but it does not seem to make a difference, and I still only have the 11 packages.

In the package manager window a couple of the packages are marked with small icons on the left. “Package_Manager_NETOS” has a small yellow triangle, and “TCPIP_Updates” and “FTP_Updates” both have green ticks. The other packages do not have any icons. Anyone know if this is normal?

Package Information for “BSP_Updates” says Version 1.4 and a date added of 09 Feb 2009. rather than the latest from the website which was relased a few days ago.

The digi web site ‘’ indicates updates at V1.0 but this is for 7.4.2, so is the problem that the version numbers for Package updates are only works until a major release. (I.E. a 7.4.1 install does not automatically upgrade to 7.4.2)?

Hello all,
The reason you cannot see any package is because they were moved from the repository. With the release of update 7.4.2 (which is being reworked in order to fix the critical issue) all those old packages are being converted to the new NET+OS version (7.4.2) and as you say, only the Package Manager update is available right now. Package 7.4.2 will be released again shortly and with it, I expect some other packages for 7.4.2.


Is there any update on when the revised 7.4.2 will be available? (Or is my package manager just not finding it?)

If its going to be a little while yet, I for one would find it very useful if the previous packages could be made available temporarily.

Incidentally, is there a recommended way to check what changes have been made to the reference versions of the various customisation - the project/bsp/platform and project/sys directories, for example?

It looks like it’s up there now

Must have arrived about 2 minutes after I stopped looking!

taken all morning to get things set up again, but looking much better now.

For future reference, if I archive all the *.dipk files somewhere, is there a way to persuade package manager to reinstall them onto a clean copy of Eclipse? (thinking of PC crashes etc).

Hello Steve.

There is a way to install all the packages in a clean installation without downloading all again. Packages are downloaded and stored into a location that depends on the package target. For example:

  • Packages that will be installed into Digi NET+OS environment are downloaded into /package_manager/temp. By default C:/netosXY/package_manager/temp
  • Packages that will be installed into Digi ESP environment are downloaded into /package_manager/temp. By default C:/Program Files/Digi/Digi ESP/package_manager/temp
  • Packages that will be installed into Cygwin environment are downloaded into /package_manager/temp. By default C:/cygwinXYZ/package_manager/temp

In those folders you will find two files for each package: *_info and *.dipk. What you need to do is to copy all the files from those three folders to a new one and then, add that folder as a local repository into Package Manager preferences page.

After this, launch Package Manager and it will find all the packages you copied.

Hope it helps, if you have any more questions or doubts, please ask them :).


Seems pretty clear, thankyou - saves a fairly lengthy download.


Has anyone successfully saved the contents of the temp folders and then used the update files to install on another machine?

Having Pointed the Package Manager at a local repository with all the info & dipk files, as in Steve’s post, the Patches & updates appear in a list and you can select them. But when you click proceed, it comes up as ‘Downloading’ and never continues with a download or installs. Can anyone shed any light?

Thanks Oliver

Now seeing a different problem - the latest two updates are shown, but when I go to download and install them, I get a message:

ERROR: Problems on secure connection

The strange thing is that yesterday I successfully downloaded and installed one package (the documentation update) out of the two that were then available (at least I think I did - file date on ApiReference.chm is 23/4/09), and it then failed on the second.

Any suggestions? No known changes to my setup. Possible port change? My firewall does err towards blocking absolutely everything, both incoming and outgoing, unless specifically enabled. I’ve tried the -clean option as well.

Hello Steve,
I think the problem is now fixed. You should be able to install those two updates now.


It is indeed, thankyou.

One bit of feedback - it would be very helpful to know in detail what’s changed/been fixed in a patch - especially when one of the files which is copied to each project has been edited (e.g. bsp config files). That’s something I find quite tricky to keep up with.


I have manged to get the update manager to install the updates,

Answer: The Proxy Patch for the Download manager must be installed first, the Package manager will then install from a local repository