Port unreachable with UDP

Hi all,

I’m quite new at using Dynamic C with my SBC BL4S100, and I have stumbled into some difficulties.

I have created an application based on some of the sample code provided with DC 10.66, where I want the Rabbit to respond to a data request by another application on a remote machine on the LAN connected through a switch using UDP.

I have not yet tried using the data handler option as displayed in UDP_ECHO_DH.c, but I want to figure out what my current issue is.

The Rabbit is capable of sending UDP packets to the remote machine, but when I try make the remote terminal request data on port 10, there is no response.

I have set up Wireshark to monitor the network traffic, and it shows an ICMP message from Rabbit saying “Destination unreachable (port unreachable)” as a reply to the request from the remote machine.

I’ve tried using different ports, but the result is the same.

Does anyone have any advice on what to do next?

Any help is appreciated, thanks.