PortServer TS 16 on Debian Squeeze

Portserver ts 16 worked fine for years over AIX. However ,in order to install it at Debian 6 i had to download the beta drivers.
I had two problems…

1)For some reason it messed up with gdm.Couldnt login at all. Reinstalling gdm solved the issue.
2)Didnt startup automatically.Fixed by sysv-rc-conf.That it because distribution incompatibility.

I see that there is a newer edition available.Are these issues fixed?

What kernel version are you running?


After setting again the system from scratch in order to be production ready i had to set RPM_BUILD_ROOT env variable…
However i had to set it to “” when i did make install…

Finnaly i had to monkey a little with dgrp_daemon init.d thing to work… It needs start and stop level different.
2 3 4 5
0 2 6 i think

Unexpectically i got tty_dgrp_{id}{number} and pr_dgrp{id}_{number}

Last time i installed beta drivers got tty{id}{number}

i cant figure out why this happened.

The build environment is a requirement.

As for the other behavior, are you using the latest driver candidate with this newer kernel?


If so, please post a typescript of the driver compilation/installation:


rpmbuild --rebuild dgrp-1.9-29.src.rpm
alien -d --scripts /usr/src/rpm/RPMS/amd64/dgrp-1.9-29.amd64.rpm

dpkg -i dgrp_1.9-30_amd64.deb

dgrp_cfg_node init (ID) (IP) (#_OF_PORTS)

ls -l /dev/tty(ID)*


Send the file called typescript from the directory where the script command was issued.