PortServer TS 4 + Binary serial data


I searched around a little before posting this, but couldn’t find anything direct. Basically, I have a Cloud Cap TASE DUO Gimbal (cloudcaptech.com), and a PortServer TS 4. These are connected via a test LAN. The DUO, a neat little piece of hardware, outputs data in a completely binary format. It is supposed to be an RS-232 port, and works fine when directly connected to the appropriate COM port.

In short it feels like the PortServer has strong desires to parse ASCII/style data (I tested it with another ASCII device and it worked great). I can’t seem to get the PortServer to just output the bit for bit binary from the gimbal.

I have tried taking a RealPort profile and changed the baud rate to the appropriate baud. I am working with essentially 3 wires for control (Tx Rx Gnd), do I need to disable a setting or something?

Anyone have any suggestions?

Thanks! -Dan


I have added a PDF drawing of my bench configuration.

Thanks for helping me out. I’m a little new to this device but it is very promising to many of my colleagues here.

Are you using a TCP connection with the PortServer port or are you using the RealPort driver on the Windows laptop?

For a TCP connection, you will want to use the 2100 (raw) port. For example, 2101 would make a binary/raw connection to port one and 2104 would refer to port 4.

If you are using a “COM” port with the RealPort driver, please post the driver and Windows version.

Thank you for the response, userid0!

I am using the RealPort Virtual Com Port method, since the software is expecting a com port.

Opening Device Manager under Windows XP, and highlighting the Multi-Port Serial Adapter, I see:

Driver Date – 11/17/2006
Driver Version – 3.6.325.0

The Device Firmware is:

Version: 82000747_T1 02/21/2007

Should I update these to more current versions? I installed these off of the supplied CD.

Thanks for helping me out!

Got it.

Forgot to put a null modem in. Silly me!

Also, changed System settings to optimize Latency.