problem writing data with digi

Hello, he’s my problem. I got two computers with Kepware drivers. Under that, I got a digi-one IAP who communicates with some controller on Data-links. I get data on the two computers at the same time BUT I cannot write any data Boolean or analog in the controller. Anyone knows which setting can solve my problem or at least telling me if the problem come from the digi or kepware driver.

Computer Computer
(kepware) (kepware)
-------------------------Ethernet protocol
…|…protocol datalinks

Message was edited by: Mister

The issue might be the PCCC command used. The DOIAP does not (and cannot) modify the Rockwell “PCCC” command which is moved by all non-CIP & legacy protocols. This is the command to read/write a specific N-file or B-file and so on.

For example Kepware writes bits using the “Protected Typed Logical Write with Mask” command (sub func 0xAB). Not all AB PLC support this, and it isn’t documented in the public “DF1 Protocol and Command Set”. It is a very useful command, but still not universally supported. Keep in mind that Kepware THINKS your PLC is a newer/fancier PLC since it talks by Ethernet! If it isn’t supported, Kepware should be seeing a 0x10 error status returned.

I’m not sure why “analogs” fail - do you mean N-file 16-bit integers? Or do you mean F-file floats? Again, if Kepware is sending a Float tagged as a Float, a PLC without a float table rejects the write. Even though the Ab protocols move all data as arrays of 16-bit int’s (even string types), the SLC5 Protected Typed command include a data-type field which much match the RSLogix ‘table’ assignment. So if file 15 is defined as B, then only read/writes tagged as binary-file-type succeed.

You should see if Kepware allows setting the PLC type, which would change the type of commands sent. Setting the type to “lower function” PLC such as the MicroLogix 1000 will reduce the range of commands Kepware will attempt to send.

The device it’s not a PLC but a controller 53MC5000. And i can write when just one Kepware it’s there but when two Kepware talking to the 53MC5000 through DOIAP, i can just read.

Does that device “speak” an ASCII or binary protocol ?
If it is ASCII based I don’t see any problem to set a Multimaster scheme with a serial device.
Have you tried RealPort or ethernet encapsulation with your driver?. Be careful with timing.
Do you have same issues with a different driver?.

In our business we use IAP to give ethernet communication capability to legacy instruments/PLC mostly serial. i.e. Omron,Red Lion, Fisher & Porter, Eurotherm, etc.

Need a quotation? Send me a PM.