PyCharm Error: Packages required for Digi Python support not found: mpy-cross

Hi all, in our corporation we want to implement solutions based on Digi XBee 3 in DigiMesh protocol. I’m having a problem running examples from the Digi XBee plugin in PyCharm Community Edition 2020.3.5. After importing the xbee relay module running it gives me the error “Error: Packages required for Digi Python support not found: mpy-cross”.
After typing “python -m mpy_cross --version” in Windows CMD, it displays “MicroPython v1.20.0 on 2023-05-02; mpy-cross emitting mpy v6.1”, so it looks ok. I tried different versions of PyCharm Community Edition (2022, 2023) and an older version of mpy-cross (pip install mpy-cross==1.9.4).
I would greatly appreciate your support.

I am running version 2023.1.3 and I do not have this issue.

I don’t know which of the examples you are working with or the firmware version on the XBee. But you may need to make sure you are running a version that is supported by the module.

Well, to resolve these issues, you can check for a Python environment, and if it still doesn’t work, then you can try after restarting PyCharm.

Thank you for your answers. I reinstalled PyCharm several times in different versions. Version 2023 crashes after a few seconds-minutes. I installed PyCharm Community Edition 2023 on another computer and it works fine.

I Appreciate The Effort You Made To Share The Knowledge. This Is A Great Stuff For Sharing. Keep It Up. Thanks For Sharing.

I got the same error although I’m running on an M1 Mac. I tried multiple different versions of PyCharm but the result was always the same by charm would lock up blame the Digi plug-in and require a force quit if I click quest quick enough, I could see that MPY-CROSS had failed to install. PyCharm Would suggest a command line to install mpy-cross that would also fail with the gibberish, worthless error codes.

The solution in my case was to make sure that bash runs with Rosetta, as if it were an Intel only program. The command “pip install mpy-cross” only works correctly on an arm-based Mac, if Rosetta is used.

I know this is not exactly the answer, but this was the only place on the Internet. I could find with a similar problem. Maybe it helps someone else in the future.