I am attempting to assign an IO address to my DIGI modem, with very little success. The modem is enabled and will not get an address, not sure why, but it is assigned on an IRQ. here is what i got so far.

cat /proc/interrupts
0: 70334 XT-PIC timer
1: 1860 XT-PIC keyboard
2: 0 XT-PIC cascade
3: 57 XT-PIC aic7xxx
4: 30 XT-PIC aic7xxx
5: 1326 XT-PIC eth0
7: 0 XT-PIC usb-ohci
8: 1 XT-PIC rtc
10: 62 XT-PIC Digi DBX2
11: 29064 XT-PIC megaraid
12: 19748 XT-PIC PS/2 Mouse
14: 7439 XT-PIC ide0
NMI: 0
ERR: 0

cat /proc/ioports
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
01f0-01f7 : ide0
03c0-03df : vga+
03f6-03f6 : ide0
08b0-08bf : ServerWorks OSB4 IDE Controller
08b0-08b7 : ide0
08b8-08bf : ide1
0cf8-0cff : PCI conf1
ccc0-ccff : Intel Corp. 82557/8/9 [Ethernet Pro 100]
ccc0-ccff : e100
d000-dfff : PCI Bus #03
d800-d8ff : Adaptec AIC-7899P U160/m (#2)
dc00-dcff : Adaptec AIC-7899P U160/m
ec00-ecff : ATI Technologies Inc 3D Rage IIC

00:04.0 Network controller: Digi International AccelePort RAS (rev 0a)
Subsystem: Digi International: Unknown device 0060
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- SERR-

A PCI card is given resources such as IRQ and memory address range by the computer BIOS.

How are you trying to assign this an address and why? Isn’t the card working? Have you tried it in a 33 MHz PCI slot?

the card is not working the problem is there are no io ports assigned to it. for whatever reason, im not sure because i dont know linux that well. every other device when I run lscpci -vv gives me a
Region 1: IO ports at ecc8, or whatever address it is. this device does not if you look above at my other post. is this a problem???

At this point, the O.S., driver version and machine brand/model information would be useful.

It appears you are running Linux but, can’t be sure. If so, the distribution and kernel version information would be useful.

i got the modem working now and dialing from minicom. I cannot activate the device though from the GUI. But to answer your question,
Redhat ES 3, kernel 2.4.21-4