RCM4000 sample program problem

I’m relatively new to rabbit so please see if you can help me out.

I am trying to use the ‘Browseled’ sample program for the RCM4000 and I can’t access the web page to control the leds -the page times out.

If I comment out the ‘brdInit’ command, I can access the page no problem and I can see the leds and buttons on the web page and they work fine.

I’ve tried other sample programs that use the ‘brdInit’ command and they all work fine, as does the SSI.c sample program from which ‘browseled’ is derived.

Any ideas about what’s going on?

Thanks in advance

can you ping the board ?

Are you using the latest version of Dynamic C? This sounds like a problem I had about 6-8 months ago. I believe there was a problem in brdInit related to 4000 vs 4010 port initialization. I can try to find the exact bits that were wrong but I believe it is fixed in the current libraries.

This is listed in the 10.07 fixes…

  • Defect #81685 fixed. On the RCM 40xx series, brdInit() no
    longer sets PE6 as an output. This was sometimes causing
    Ethernet to stop functioning.

That was it. I was using DC 10.05, the upgrade fixed it.


I apparently have the same problem wit the RCM3700 and DC9.52.

Seems like the web (http) part works for a while then hangs. After hang, I can still ping. When it hangs, it never makes it to the http_handler.

Another question: Where is the brdinit() that is used by the RCM3700 located?

HELP!!! Does Rabbit Support ever read this forum or am I’m going to be forced to fill in the web form???

UPDATE My ‘hang’ seems to be related to the environment. I have the RCM3700 behind a router/firewall as a virtual server with the redirection set up to be the external public IP & Port. Then testing with a system also behind the firewall and it locks up occasionally. When it does hang I am still able to use the private IP so it seems to confuse the router or address translation.