RFU 2.50 does NOT work with the new Ver4.0 SystemBase Multi-1/USB RS232 Converter

Systembase has been the recommended USB to Serial Adapter for use in programming the Rabbit BL2600 for many years.

They have gone through several design changes, and recently this year they have changed to a new version, designated Ver4.0 on their sticker, and they are no longer working with the RFU 2.50 utility.

I connect to my BL2600 using RS-232, and that works with the cable, I can communicate with it, however the programming does not work.

I have tried updating drivers from the included CD, to Windows Update’s FTDI Drivers, to the SystemBase drivers on their website. None work.

Does not work on Windows 7 64 bit, or WinXP.

OK it works now, some comments:

  1. Systembase has recently posted new drivers as of 9/16/2013 - Had to download and run those.

  2. RFU.EXE does not seem to like Com Ports numbers above Com 8. So if you plugin the USB-Serial Converter cable, and it comes up as greater than Com 8, try uninstalling your unused, enumerated Com Ports using these instructions:

  3. I also had to disable Enable Processor Verification and enable Use USB to RS-232 Converter Cable.