Running Dynamic C under Linux/Fedora/Wine?


My super-duper Rabbit Dev Kit RCM440W arrived. Somewhat bizarrely, it promised an international power adapter in the blurb and on RS website, but arrived with a US one. Once that detail had been sorted out with a soldering iron, it was on to try it out!

It works perfectly under Windows XP, but as Windows is consigned to an alternate boot-up on the kids’ computer inconveniently located under the stairs, it’s either go on a diet to lose enough weight to be able to squeeze under there or, much more preferable, get it working under Linux (Fedora 11) and Wine.

  1. It recognises the usb serial converter FTDI (checked through dmesg and usbview).
  2. If the file permissions are wrong, Dynamic C won’t open the device. If they are set correctly, DC is happy. So I’m pretty sure Wine’s COM configuration is okay.
  3. Trying the suggested WifiScan.c sample programme results in the splash windows saying it is loading pilot, etc. up to the point where it tries to download to the target. Then, depending on the baud rate settings, it either flashes up a message too quickly to read and just leaves a ‘Communication Error’ diagnostic on the status line - or leaves a message ‘error sending pilot bios an internal error in the target communication’
  4. The time between pressing F9 and the error message appearing is not affected by the baud rate settings, so I’m guessing that there isn’t any transfer going on before it gets to the error point. I could be wrong of course!

My guess is that it is something to do with the stty settings, but google can’t help.

Thanks in advance to anyone who can help me.

I have the same problem.

The compiler works great. Downloading the software fails while sending target pilot.

I’m using Dynamic C 9.62 and Wine 1.0.1.

How much work would it involve to write a new download util? It does not have to be combined with the compiler. I’m quite often having problem with downloading the program on WinXP as well, so I don’t have the greatest confidence in the downloader-code in its current state

It’s a shame that all of DC works great in Wine, except the downloader.

Following your suggestion, I wondered if there are already any download utils written.

I tried downloading: ftdi-eeprom-gui and it will try to access the device, but I can’t get anything successful going.

Also tried avrdude, but I may well have mis-understood this one! Is it trying to programme the chip in the usb-serial converter rather than the rabbit module?

ftdi-eeprom-gui is to program the flash in the ftdi usb chips, so that you can set vendor ids etc …

avrdude is a downloader for Atmel AVR microprocessors.

I also tried OpenRabbit with limited success.