RX packet id 0x81, i would like 0x80

Function set: XBEE 802.15.4
Radio: XB24
Version: 10CD

when my coordinator sends a RX packet to PC, the packet type ID is 0x81 and byte 2 & 3 show the 16-bit MY value of the sending radio.

although iā€™m using 64-bit addressing when sending from radios to the coordinator, so i thought the packet id when going into the PC from the coordinator would be 64-bit and not 16-bit. :wink:

what option in the function set do i change on the coordinator so the packet id is 0x80 and RX packet is sent to PC with the 64-bit address of the sender versus the 16-bit address.

on the coordinator i have these values set:
DH=0
DL=0
MY=0
BD=3
RO=0
API=1

thanks

I had this same problem.
It seems, strange enough, that you need to set
MY = $FFFF
on the sending device.
Apparently it uses its 16 bit MY address for sending if available, even if you use the 64-bit address api identifier 0x00 for TX request