Sleeping using Pin Sleep

I’m putting the XBee into sleep by using the pin sleep. The host would wake up and read sensor at predefined interval. Upon completing sensor reading, data would be sent to the XBee by waking up the XBee using the pin sleep and also checking the CTS pin before sending. I found that 80% of my packets are lost all the time. Connection is point to point between Coordinator and End Device. When, the End Device is replaced with a Router, I managed to get 100% reception. Did I miss out on any settings?


We’d like to see your config. You can get this thru x-ctu.

The CTS line will tell your processor when the end device has woken up, but that’s about it. depending on your settings, it’s possible that your end device was asleep too long for the parent, and the parent purged the end device from its child table.

When the end device wakes up and is ready to send, it finds that it is no longer associated to the network any longer and needs to re-associate to a parent before the information your processor sends will make it.

You can help verify/resolve this by doing a couple things.

One, set the SP, SN combination on the parent device long enough such that the end device will never get purged from the child table before the end device will wake up.

Use the API version. If the end device is purged from the network, your processor will receive a status message that the module has disassociated from the network. Wait until you receive the associated message and then send your data. If you just directly send your transmission, the API will also give you an indication as to why the transmission failed.

You can also send the ATAI command to check the association status of the module before you send your message. The best idea is to just set your parent such that it shouldn’t ever be purged in the first place however.

Here’s my configuration on the End Device:


I intend to set the sampling interval to 10 minutes actually. Now I’m going to try with SP = 0xAF0 and SN = 0x19 for the Coordinator which comes to 2800 x 10 ms x 25 = 700 s.
Do you guys think this is adequate?
Thanks for the informative reply. :slight_smile:

It’s working already now for direct Coordinator-End Device connection.

For router, I will set SP = 0xAF0 and SN = 0x19.
Should I also set SO = 0x04?

I would shy away form using the SO parameter unless you know hat it is necessary and in this case it doesn’t seem to be.