sock_init timeout

Hi! I am working with a RCM5400W and have a problem when trying to stablish wireless communication, because when I make a function call to sock_init I get this error message:

While Debugging: Timeout while waiting for response from target

Does anyone know how to fix this?

I appreciate the help!

hey i have the same problem!!

how you fix it?

I had the same error.

I found the problem,the problem was in the hardware,in sometime I plugged the device with a wrong voltage and the ethernet part didnt was running. I have tried with a new device and the right voltage and now everything runs well.

perdona por mi abrupta solicitud.

(mejor en español) que tal te fue con ese problema? si pudiste resolverlo, te agradecería que me ayudaras por favor.

como dato de mi caso estoy usando el RCM5400W pero sin el Developer kit por el $$. Creo que con darle voltaje y GND y su cable de programacion fue suficiente. Todo codigo que no tenga que usar la comunicacion WiFi trabaja sin problema (ejm sumar etc, cualquier proceso)

as data in my case. I am using the RCM5400W but without the Developer Kit for $ $. I think with Power and GND and usb wire programming was enough. Any code that does not have to use the WiFi communication works without problem (use variable to add them, subtract, any process)

please any help.

otra cosa los leds DS1 y DS2 (Link, Act) del core nunca han encendido para indicar que el WiFi trabaja

otherwise the LEDs DS1 and DS2 (Link, Act) of the core have never lit to indicate that the WiFi works

please help!

i don’t get the error sock_init,
i update to DC 10.64 and i try change the baus rate and finally i can see running the first line of return “Starting scan…” (sample: WiFiScan.c)

finally i can see flash the led DS1 (ACT) bun only one time :frowning:

and next i get the error

While Debugging: Timeout while waiting for response from target

some help please!

Even though the debug interface times out, perhaps you could you could see the return value of sock_init()? Try this:

unsigned char rtn_value;

rtn_value = sock_init(1);

As I recall, a return value of 0 is OK, 1 is an error, and values > 1 are reserved errors.

If it is hanging in sock_init(), you could try sock_init_or_exit() and possibly see a little more?


now I have no error stock_init_or_exit (was solved by changing the baud rates) the error I have now is

      While Debugging: Timeout while waiting for response from target

in the sample WiFiScan.c only i can see “Starting scan…” after crash! :frowning:

somo idea to fix?

ojala silrb17 me puedas ayudar en el otro error si pudiste resolver tu problema.