While Sending User Program, Timeout while waiting for response from target

Hello all,

I have a new rabbit RCM5700 starter kit (bought on “embedded world 2009” in Nuremberg) and it is already connected to the PC with the USB cable (not COM). The green LED (power) is on, the status seems OK.

Now I compile the file PONG.C, some other files are being compiled also (automatically) and then the result is being loaded to the flash. A counter is showing the progress, the last value is 30720.

Then after a few seconds I get the message:
“While Sending User Program, Timeout while waiting for response from target”

Who can explain me why this happens?
Thank you, Cornelis

Now it works!

I changed the download and debug baud rate to 115200

The error disappeared, although I work with the USB cable and there the baud rate should not influence the connection.


I had the same problem but mine seemed to be the rabbit board didn’t like my USB hub.

The RCM5600W interface board (part number 20-101-1283) doesn’t seem to like USB ports which are on laptop docking stations, either. But I have not tried all the USB ports on my Dell docking station yet to confirm that. For people like me who are new to the Rabbit Mini Core boards and Dynamic C, it seems a good idea to start simple and connect directly to the PC or laptop, using a USB port which is known to work.