While sending pilot BIOS Timeout while waiting for response from target

I just received my MiniCore RCM5600W Standard Development Kit and after installing the Dynamic C and drivers I plug in the board, load the scanwifi.c program into the compiler, set the com port (13) and hit F9 :)…after a bit I get the message in the title.:confused: What should I have done to get this working?

Thanks, Stephen

Well at least you got past the first possible massage nl. “While sending cold loader, no rabbit processor detected”, which means Dynamic C can initially see your rabbit.
I would check for loose programming cable connections, also make sure the prgrammer connector makes fully contact with the rabbit programming port.

Lastly your using comm port 13, which seems a bit high for a standard PC comm port. Are you using a usb -> serial converter. They are notorious for not working with the Dynamic C programmer.

Rabbit did introduce a checkbox in the Options->Project options->Communications tab to enable usb->serial converters, but I am still not convinced it works.

Thanks, I’ll check the connections and the settings. The module has a usb connection so I’m just using a straight usb cable. The converter is on the development board so I would hope it works.

Three years late we faced the same problem.

Our situation got better by using a Trendnet USB to serial converter, the generic converters produced that error 99% of the time.

Also we had to check conductivity on both ribbon cables, to discard problems there.

Good luck!

Well, no real luck so far. It still throws the error message 99 percent of the time. Twice I got a window with the filename I was trying to load but nothing happened after that. I guess nothing is as easy as they make it look in the literature. I’ll keep plugging away for now.

Hi, Can you try a simple sample like pong.c?
Do you get the timeout error with that sample?

No, I just tried that and I get the same message. It seems to be just after the negotiating baud rate message. Is there a way to reset everything back to “default” I’ve changed things now and don’t have a clue just what might be causing the problem. Two quick questions, what are the baud rates for download and communication and should there be one or two stop bits?
Thanks, Stephen

Well on my system 1 or 2 stop bits doesnt seem to have an impact. Both works.
For the baud rates, I would for now set them low, until you can get communications happening. Furthermore play with the comm ports, it could be that the wrong one is assigned.

But I repeat that many times I have seen your problem, and it was down to a poor connection between the programming cable and the rabbit. Try to apply some shear pressure on the connector to see if it has any effect.

Well, I tried a different cable on a different port and got the same message (after I changed the port in options > project options , DUH)

Had the same problem until I switched to the enclosed cable. Works fine.

Well, this weekend I had time to pull the computer out an connected the cable to the back instead of using a port on the USB hub. It works just fine that way so I will leave it. Thanks to all for the help.

I had a post on this forum a while back with pretty much the same issue. The RCM5700 doesn’t like working through a USB hub. I think it’s a timing thing, the slight extra delays mess up the data transfers.

I had this same thing happen to me with my own 5600W. In my case, the PC is a Dell Latitude E6400 laptop docked to a Dell docking station. I had connected my USB cable from a USB port on the docking station, to the interface board carrying the 5600W. That caused the error. Solution was to take the laptop off the docking station and plug the cable directly into the laptop’s “power share” USB port on the left side. If it first you don’t succeed, try a different USB port.


I don’t think it’s a powered vs unpowered port thing. I prefer using a powered hub rather then direct connected ports for the simple reason that I’m getting too old to be soldering them dang tiny SMT fuses on the mother board ports. It’s a lot simpler to toss out a hub and get a new one when you mess up and draw too much power. That being said, the problem with the rabbits seems to be a timing thing, they can’t deal with the extra delays involved with using a hub. Actually, I’ll place a small wager it’s not the rabbits as much as Dynamic C. Maybe they can soften up the timing a bit for the next release.

Ditto the earlier comments for an IBM ThinkPad. The RCM5600W would issue comms errors when I used the USB ports on my IBM ThinkPad docking station. Moved the USB to the laptop itself and it worked fine.