Timeout while waiting for response from target

I just started working with a BL5S220 yesterday, and am encountering the “Timeout while waiting for response from target” over 90% of the time when attempting to compile/run programs.

I’m using Dynamic C 10.60 with a Rabbit-provided USB serial cable running WinXP pro.

This occurs even with the pong.c sample. I’ve searched for solutions, and have checked/tried the following things.

  • Reduced the debug baud rate to 57900
  • Disabled baud negotiation
  • Confirmed my USB serial port settings match the DC comm settings
  • Tried both front and rear panel USB ports (I’m not using a hub)
  • Adjusted the Serial Response Timeout, USB to Serial Delay, Serial Retry Count, Serial Poll Interval settings in Default.dcp
  • Restarting DC after every upload
  • Resetting the target after every upload
  • Checked the programming cable for damage

Does anyone have any further ideas for things to attempt?

You could un-install DYnamic C, then when re-installing, make sure your product is attached. It is possible the correct drivers are not being used for your USB cable.

Thanks for the idea, but I still experienced 10 consecutive failures (with target resets, DC restarts) after re-installing.

My problems have disappeared after updating to Dynamic C 10.64.

i have the same problem, i have 10.62 i try to update

i update to DC 10.64 but i have the same problem, i keep trying.