[Solved]:I'm unable to read accurate ADC values (I can't think of anything else to do)

Hi everybody,
I’m trying to read analog voltages with an XBee S2C TH from different kind of temp sensor, and the values obtained by the ADC are inaccurate (a small shift of 20-30 ma appears) and they are very oscillating.
The sensors that I’m using are:

  • Vcc is 3.1, annd it comes from an electrical trasnformer, 0.5A, connected to the power supply grid.
  • LMT84 ( the output works in a range less than 1.2 volts)
  • NTC 10KOhms (series-wiring with a 270KOhms resistor, 0.1% tolerance, so the input to xbee never reacher values hihger than 1.2v )
  • A simple voltage divisor to check the values

To check the values that the ADC converter returns I use also a oscilloscope, and I can see an extrange behavior:

The voltage in the XBee inputs suddenly drops and the returns to its expected value, (I’m suppousing that this is the cause of the inaccuracy), In the other hand, I’m sure that it’s related with the sleep modes, because modifying these parameter the behavior also changes (In fact if SM=0 the oscillation is continuos). (It must be related with the RF process)

  • I’ve used every different XBee devices and different inputs,
  • I’ve tryed wiring AREF pin to vncc and also, not wiring it,
  • I’ve used capacitor (0.1uf) from the input to 3.1v or from the input to GND
  • I also have filtered de Vcc with a capacitor (different values have been tested),

Nothing has worked, I’ve read a lot of documents, and none shows anything different from what I’m doing.
Sincerelly, I’m lost and I can’t understand the cause of the problem.

In conclusion I’m unable to read an accurate value from an analog input…

Is there something I’m not understanding well or something else I should do?
Thanks in advanced for your support.

To provide more information the raw input value in the XCTU drops
from 604 with SM=4
to 480 with SM=0

I’m a bit embarrassed but I’ve discovered the source of the error.
The inaccuracy in the measurements was caused by the low quality of certain components, mainly the poor performance of the breadboard.
Yesterday I soldered all the components in a pcb and the problems disapeared, I had already tested the circuit on different possitions into the breadboard, so in the first instance I thought that not the complete breadboard could be broken and showing this unexpected behaviour.