SPI pins on Xbee 3.0 MMT don't let me blink a led

Hello, i working with a Digi Xbee 3.0 MMT device and i just had a trouble with communication and consist on the following:

  1. the host Xbee attach to mi PC discover the remote one, and can read all of their configuration
  2. i can write some parametters like Baud rate (BD),MicroPython Auto start (), D0, D1, D2, D3, D4, D5.
  3. But other parametters like D8 NA[2], and SPI interface don’t let change the default Option[1]
    the error message said:
    “Error writing the following AT parameters
    -P5: Invalid parameter”

And so on with P5,P6 P7 P8 and P9 pins

  1. i Previously tried a MicroPython script on the host xbee with each of the SPI Pins and it worked fine, but i flash this same script on the xbee remote’s file system and don’t work.
    the configuration on each xbee (host and remote )are the same:

Product Family: XB3-24.
Function Set: Digi Xbee Zigbee 3.0.
Firmware Version: 1007.

Thanks in advance.
Link to the video where you see what I just described

Hi! I got exactly the same problem, after firmware update my uart get disabled and the spi is enabled by default. I cant switch to the uart again with the same error.