Can't activate UART and disable SPI on xbee 3

Hi guys! After a firmware update from 1003 to 1009 my device (xbee 3) stopped sending and receiving commands via uart. The SPI pins are all enabled by default since the update. I tried to disable them but the XCTU says that the AT command are incorrect, I also connected to my xbee via bluetooth tough the app and its still the same error. I read the hardware manual, and turn on the xbee with de DIN pin to ground to restore the uart but nothing happened.

We are developing a product based on xbee 3 (more than 100 devices were bought), so we need to solve this or will move to another hardware solution.

Try updating to firmware version 100A. You might need to issue a remote AT command to restore the firmware to default settings to solve your issue.

The only way I can communicate with my xbee is via radio, the uart is inactive and my custom board is not using the spi port. When I try to update via radio with a coordinator board the xctu says that there was an OTA error, something about size mismatch.

Well I have entered to bootloader mode and updated the fw to 100A version, the uart still not working, but it is not a hardware issue because in bootloader mode I sended and received data via Xmodem with tera term.

You can’t do an OTA update to the same version. The Zigbee protocol will not let you.

Try forcing command mode with an XBee interface board and once in command mode, do an ATRE, WR.