firmware flash / uart disabled


Yesterday, I’ve flashed my xbee with a ‘zigbee router/end device analog IO’ firmware, and I’m unable to reverse it to another firmware because the uart is now disabled.
I’ve read every post on this forum, tried every suggestion, nothing works.
The xbee is connected with the rx, tx, cts and rts via an max232 to the serial pc port. I’m unable to read or reflash via X-CTU, I always get the error “Programming modem…Detected baud rate difference.”
I have another working xbee, when I attach this one to my pc, I can read/change the parameters of the ‘not working one’ via ‘remote configuration’ in X-CTU , but I’m unable to reflash it over the air with antoher firmware.

I tried several times holding the reset pin to ground while writing the new firmware, but I always get the same baud rate error.

The baud rate I use is 9600 baud, also tried different rates, but nothing works.

Can you help me?

yeah, I finally found a solution!
I connected pin 9 (DTR) to ground, and pin 6 to 3,3V… reflashed and it works! no baud rate error.

Hope this helps!