Restoring from a bad configuration

I was using X-CTU to change my xbee module from the default Router function set to the Router/Endpoint function set. I let the default settings that X-CTU gave me (which included enabling CTS and disabling RTS) and now I can no longer communicate with the device.

Online support has repeatedly pointed me at this video. I don’t have a development board but I’ve tried the procedure with my setup and I am getting a baud rate mismatch error. I am using 9600-8N1, no flow control for my connection (though I have tried hardware flow control).

I was told that the Router/Endpoint function set disables the radio’s UART. Will I still be able to restore the xbee?

Thank you in advance.



You can force writing another firmware on your Xbee device through X-CTU. And check while writing your PC Baud rate and Xbee module Baud rate is same.

That’s what I’ve been reading but it doesn’t work. I get a baud rate mismatch even though I’m certain that they are both at 9600 baud. I’m not using any flow control either, but I don’t know if that is a problem.

How does the flashing work? Am I actually talking to the XBee’s bootloader instead of the firmware that gets loaded? And if that’s the case, how large is the window for initiating that connection? I’m asking because all of my software is running in a virtual machine and I was thinking that there may be the possibility of the serial messages getting delayed slightly too much.

Thanks for the reply.