Restoring from a bad configuration

(This was originally posted to the wrong forum).

I was using X-CTU to change my xbee module from the default Router function set to the Router/Endpoint function set. I let the default settings that X-CTU gave me (which included enabling CTS and disabling RTS) and now I can no longer communicate with the device.

Online support has repeatedly pointed me at this video. I don’t have a development board but I’ve tried the procedure with my setup and I am getting a baud rate mismatch error. I am using 9600-8N1, no flow control for my connection (though I have tried hardware flow control).

I was told that the Router/Endpoint function set disables the radio’s UART. Will I still be able to restore the xbee?

I was also wondering how the flashing process works? Am I actually talking to the Ember bootloader instead of the Xbee firmware that gets loaded? And if that’s the case, how large is the window for initiating that connection? I’m asking because all of my software is running in a virtual machine and I was thinking that there may be the possibility of the serial messages getting delayed slightly too much.

Thank you in advance.


Hii just try following mathod… it works fine…

1.Connect the interface board to the computer via appropriate cable (USB or Serial) (If using Serial, connect power as well)

2.Make sure the XBee module is NOT plugged into the interface board

3.Open the X-CTU program and select the proper COM port.

4.The first screen you see in on the PC Settings tab. On this tab please change the baud rate to 38400 and put a check in the “No Baud Change” check box.

5.Navigate to the Modem Configuration tab

6.Select the proper modem type, function set and firmware version from the 3 drop down menus located about 1/3 of the way from the top of the window.

7.Click on the Show Defaults button and put a check in the “Always update firmware” check box.

8.Click on Write. (Yes, the module is NOT plugged in) An Action Required box will appear. This is good. When this happens, hold in the config/reset switch on the interface board and CAREFULLY plug in the module and then release the config/reset button.

9.You should now see that box disappear and a progress bar will appear along the bottom of the window. You will see the bar progress and then the box will appear again. This is good. Just hold in the reset switch on the interface board for about 1-2 seconds and then release. The box will disappear and the status at the bottom of the window will show that the write was complete.

10.Go back to the PC Settings tab and change the baud rate back to 9600 and uncheck the “No baud change” check box.

11.Click the “Test/Query” button. You should get a clean bill of health.

Hello all,
I am experiencing the same issue described here. I tried the procedure suggested by shahrj1988 and it did not solve the problem. I also tried the procedure suggested by lynnel. I was able to follow the instructions provided, accessed the bootloader and reflashed with the default software. However, the problem persists even after completing the process described. Unable to get version number (AVTR) Baud rate difference detected. If anyone has encountered/solved this issue, I would be very grateful to hear about it.
Thank you,
Craig Verrill

I’m not sure where you got that baud rate, but those instructions result in the same message:

Getting modem type…OK
Programming modem…Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Lost communication with modem
Write Parameters…Failed

I’ve tried the default baud rate as well as the last known baud rate and I get the same message every time. I am completely lost. Has anyone seen this behavior before or know how to fix it? Thank you.

Give this procedure a try:


Try this procedure.

–Mount your xbee module on XBIB-R-DEV Board (RS232 breakout board) and connect to the PC COM Port 1, but keep the power supply removed.

– Go to XCTU and select COM 1 and select interface baud rate as 115200.

– Go to Modem Configuration Tab, select the modem type, function set and firmware version properly and select show default.

– Now click write and as it shows ‘getting modem info’ connect the power supply to the XBIB-R-Board. One window may pop-up asking for reset the module, than reset the module and wait until the programming the firmware and at command configuration is completed.

– Once programming is completed, unplug the power supply from XBIB-R-DEV Board and plug it again.

– Now select the baudrate as PC interfacing baudrate as 9600 and click on read button in the modem configuration tab.

Note: Most proffered firmware to write to force the firmware on the XBee module is Zigbee Coordinator API (2170). Once you are able to read successfully programme it again to required firmware.

Note: If this procedure fail for you that also select on the ‘always upgrade firmware’ option in the modem configuratio tab and try the same produre and write it again.

cverrill - you need to explain more complete which Xbee and which firmware.

A few of the combinations have no serial port, so XCTU cannot talk to them. Those units can only be queried/configured remotely via wireless packets.