XBee Modem not communicating with X-CTU

I have several Xbee Pro modems that are not communicating with X-CTU. When I tried to write a new function set to them, it failed halfway through, and now I can’t find any PC settings that will allow me to communicate with them.

How can I restore these to factory defaults without being able to find the correct PC settings?

This seems to happen far too often!



Which XBee module are you using?

Select proper modem and Function set in the modem Configuration tab, enable “Always Update Firmware”, click on “Show Defaults” and click “Write”.

For Series 1 modules try with the Baud Rate - 115200, You can download new versions, click on “Download new version” in the Modem Configuration tab.

Series 2 modules supports ZigBee and ZNet 2.5, You can refer the following link http://www.digi.com/pdf/chart_xbee_rf_features.pdf


I am using XBee Pro Series 2 modules. Trying to set them up as XBP24-ZB Router Devices

I still get unable to communicate errors. I have already tried all the different baud rates, even though I only ever set them up on 115200.

The link you provided doesn’t go anywhere unfortunately.

Are you getting this error when you do Test/Query.

The module may not be programmed properly. Try with the following

Dont do Test/Query, go to Modem Configuration tab,
select proper modem and Function set, check the version , latest version is 2X8C, click on “Show defaults”, enable Always Update Firmware and click “Write”.

Hope this helps.

If you use XBee Pro Series 2 modules, so exactly at which point error is occur. Tell me I’ll definitely help you.

Check the below link: