HELP needed to configure xbee modules

Hai! I purchased 2 Xbee series2 modules. When i tested the configuration using X-CTU “PC setting” it gave me,


but, when i read it at “MODEM CONFIGURATION”, its not reading. So, would some one help me to config these two modems to get inter communicate BYTE-BYTE with each other.
I dont want to config it in “PAGE WRITE”.
Thanking you in advance…

You may need to re-write the firmware on your xbee modules. I would recommend the following:

  1. Open up X-CTU and go to the Modem Configuration tab

  2. Then, on the same tab, select the proper modem (XB24-ZB), Function set (Zigbee Router AT) and firmware version (2264).

  3. Then select the “Always update firmware” option and click the “Write” button. This should write the firmware to your module (may ask you for a reset).

  4. When it completes the firmware update, click the “Read” button and it should successfully read your firmware version and parameters.

For good practice I would also UNSELECT the “always update firmware” option.

Hope that helped, good luck…

Thanks for the reply…
I will go through it and return u back soon…

HAi! I have checked what u suggested. But my X-CTU is showing modem (XB24-ZB), Function set (Zigbee Router AT) and firmware version (2221).
I have an another doubt! I want to mutual communicate between two “Xbee series2”, but u said to config one as router. What about the other…

One requirement is that a Coordinator sets up a zigbee network, so I’d say one should be a Coordinator. As for the other module, Router or End Device would be fine, depending on how its powered. Router would be a good choice for a mains powered module, but you’d want to select end device if it will be battery powered.

Right, in order to network your xbee modules you will need to have ONE module setup with the Coordinator firmware (XB24-ZB, Zigbee Coordinator AT, 2064). And your other module(s) can be setup with the Router AT or End Device AT firmware like Admin said.

Once you setup a coordinator, a simple way to confirm that you have a connection with your other module(s) is by clicking on the “Remote Configuration” menu option (in the Modem Configuration tab). Then in the new window click “open Com port” and then click “discover”. Your other modules should show up here…this will need to be performed from the coordinator side.

jjfattz, this method of determining if one module sees the other by way of whether or not it can configure it can only be accomplished if the Coordinator is API-enabled or using API Coordinator firmware.

The AT Coordinator firmware in your reply would NOT be able to remotely configure an XBee associated to it.

Thanks for correcting me on this. I should have pointed out that he would need API mode/firmware to accomplish that. Sorry for the confusion.


1> IF MODEM TYPE= XB24-B then is it possible to download firmware 2264 (which is for XB24ZB => Zigbee Router) in it.? I mean is it compatible?

2> if My two modems are having firmware 1020 then it cant communicate with each other?

3> Could please guide how to start with configuring peer to peer communication between two modems? How 1 modem will address another another and vice-versa…?

 Specification of both modems are like
 Series 2
 Modem Type: XB24-B
 Firmware Version is 1020


Ans1 : Yes It is competible. You can Download firware 2264. for function set XB24-ZB. But now 2270 is available. So you can update it before writing to the module.

Ans 2: No, if you want to configure one module with XB24-ZB with function set “ZIGBEE ROUTER AT” and firmware version 2270 then other should be configure with function set “ZIGBEE COORDINATOR AT” with firmware version 2070.

Ans 3: before writing the modules, after selecting Modem type, Function Set and Firware version, Click on the Modem Configuration–> Parameter View –> Show defaults. Then write the Modules.

@shahrj1988 thanks…!
1 more thing i would like to ask…

Default parameters of these firmware are enough for communication? What kind of addressing would it would be?

thanks again…

@shahrj1988 thanks…!
I configured two modems…
It really works…
Thanks a lot…!