problems with x-ctu to update a new firware on xbee series 2

Hi to everybody…i have a problem with a xbee series 2 module…The 2 boards can’t communicate each other and using x-ctu software i can’t read the firmware version. The answer is this:

Failed to enter command mode
Unable to read Version(ATVR)
Read parameters…Failed

When i try to write a new firware i get the following answer:

Getting modem type…OK
Programming modem…Lost communication with modem
Write parameters…Failed

Someone had the same problem?


1 Like


You may take a look on this thread,,511#1898

BTW, Which firmware version did you try to upgraded ?

1 Like

I tried this and it works for me.

Remove the RF modem while the power is on.

Under Modem Configuration tab,

  • Checked “Always update firmware”
  • Select Modem, Function set, Version (I used the default version, 1241)
  • Select 96000 Baud
  • Click on WRITE button while the modem is not install. The Reset message window pops up. Now install the RF Modem, then press reset. If the pop up window did not vanish, click on Cancel button. The modem will reflash as normal. At this point if the X-CTU does not respond, click on WRITE again.
1 Like

All, you should aware of firmware version 1741. I would not try it again until Digi provides more info on it.

1 Like

Hi i read the link you have signaled but my board continues to not work :frowning: … Initially thanks for the link…I’ve tried to upgrade ZNET 2.5 ROUTER/END DEVICE AT version 1241… The answer is always the same:

Getting modem type…OK
Programming modem…Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Lost communication with modem
Write Parameters…Failed

have you an idea to solve the problem?

p.s. After many proves now i don’t obtain OK message after “+++” sequence…Please help!!!


Message was edited by: badu

1 Like