Problem with Firmware Update


I have a serious problem with one of my XBee Series 2 Moduls.During a firmware update a failure occured, and now I am not able to communicate with the modul anymore.

I tried to restore the factory settings ,however, I stil can’t communicate with the module.
I use X-CTU for firmware updates.

Is there any possibility to restore the factory settings?

Markus W.

What firmware had you last loaded on the module prior to not being able to talk to it anymore?

Reason I ask is that some of the firmware loads will disable the serial uart on the rf module intentionally, more specifically the AIO, DIO, and Sensor Adapter firmwares. If you loaded one of these firmwares on a module, the behavior you see would be expected.

To be able to talk to the rf module via a dev board, etc. you’d need to load a uart-enabled firmware such as router/end device AT (or API if that’s the desired usage).

If none of what I wrote above is applicable to the version of firmware you loaded last, try changing the firmware on the rf module with the XBIB board unpowered. When you get to the point where it pops up a box asking you to press reset, plug the power into the XBIB board and that box should go away, and hopefully the new firmware loads at that point.

You could also try the following with the X-CTU to force a firmware update.

  1. Uncheck the “Enable API” box in the PC Settings tab.
  2. Check the “Always update firmware” box in the Modem Configuration tab.
  3. Select the right modem type, function set and firmware verion in the Modem Configuration tab.
  4. Power off the XBee or hold it in reset. (If it is in an XBee serial or USB interface board from a dev kit, hold the reset button.)
  5. Click on the “Write” button in the Modem Configuration tab and wait a couple seconds. A new popup window should come up.
  6. Release the reset button or power on the XBee.


i’ve got exactly the problem, admin described:

After loading the “XB24-ZB ZigBee Router/Enddevice Analog IO” firmware on my XBee Series 2 module I cannot access the command mode. If I try to write a new firmware via X-CTU, it fails and the popup window shows up.

How can I load a uart-enabled firmware on it? I tried the five-steps-reset-pin-approach described by damons, but it doesn’t work.

Message was edited by: Jewo

Hi, I followed those 5 steps after getting the same error, but the popup window asking me to power on the XBee won’t disappear. Is there anything else I can do?

Does enabling or disabling hardware flow control make a difference? What version of XCTU are you running? (Right click the X-CTU title bar and select “About”.)

The popup window showing up isn’t necessarily a failure, it just means you have to hit the reset button. As for loading firmware over the AIO firmware, just make sure you have the “Always Update Firmware” box checked on the Modem Configuration tab before you hit “Write”. Hopefully that gets you up and running.

same problem here… even i press the reset button of the RS-232 board the modem doesnt response or its unable to communicate with the modem. how to enable UART firmwarE?

admin please update the X-CTU that doesnt disable the UART. i am also having trouble with firmwares. my modules cant write firmwares using RS-232 board and it cant also read it always says unable to communicate with the modem. on the other part, using USB dev board it can read but i cant write firmware on it. it always says unable to communicate with the modem. my modem is xb24 functionset 802.15.4 version 10CD. i followed the steps above and its no used it doesnt make my modem communicate well. It says lost communication with the modem. thanks

As mentioned in the other thread Dioxden08, I think its time to call Technical Support to walk through this with a Support Engineer.