Replace analog IO firmware


I installed the analog IO firmware on one of my series 2 nodes from X-CTU without realizing that it would disable serial communication. How can I replace that firmware now? Thanks!

I think the modem needs to be flashed. Then you can try for other setting. For this you need the development board with a reset button on it.
To forcefully write onto the module:
Open X-CTU –> Modem Configuration –> Select XB24-B as Modem –> Any function set (ZIGBEE Co-ORDINAOT AT preffered) –> version 1020.
On the development board press the reset switch and while keeping it pressed select “write”. After some time a dialog box will appear, ignore it and keep the reset button pressed. Look for a change in the progress bar.
If it changes then maybe the firmware is loaded properly and then you can try other configuration. If this doesn’t work then try releasing the reset button when the progress bar changes.
Let me know if this works (worked for me).

change the loaded firm ware in the module. i changed it and got succeeded in installing the new one and better chose some configuration that suits u

I got myself into the exact same situation. With your advice, I was able to reflash the XBee.

I don’t have an official development board, but I understand the development board doesn’t really do much. I do have my Xbee on a bread board, and I wired up a button to reset.

I held the reset button and tried to write. I dialog box appeared as you said, but I never saw any progress in the progress bar. What I found was if I release the button too soon, it fails, but it I keep it held for a minute or so before releasing it, it succeeds.

I would be nice if someone from Digi could tell us if there is a proper way to flash an XBee in this state.

Anyway, thanks for your help.

You are welcome.
You are right. I searched all the documents but none of them give the solution to the problem facede by us. (atleast in the ones I read.) Maybe digi should have a trouble shooting guide.

I made the same mistake - installed the digital IO firmware and can’t get rid of it. I don’t quite understand your above explanations as I don’t get a “progress bar” in X-CTU.

In my case:

  • I can still access to the module over the air with a 2nd X-Bee module and X-CTU remote configuration (so - I know the X-Bee is still working)
  • However all attempts to change the feature set back to something that uses the UART over-the-air fail (it’s not clear from the documentation if this is actually supported or not)
  • When I try the procedure you suggest, i.e. connecting the module via an FTDI USB cable:
    • in AT mode I cannot access at all
    • in API mode, X-CTU does detect the module but shows a strange number instead of the ID it should show
    • still in API mode, I cannot read the module configuration data
    • when attempting to write, it fails – but I never get a “progress bar” during which I could reset the module.

I would be thankful for ideas/recommendations.

Well - it’s not that easy: you will notice that due to the fact that the UARTs are disabled you cannot change the firmware any more.

Even with a uart-disabling firmware on a module, you can still flash a different one which re-enables the uart.

For instance, if you loaded AIO/DIO/Sensor adapter firmware, just re-flash the module with Router AT and you’ll be able to talk to the module again.

Its kind of a “blind” update as you have to manually select the modem type, function set, and version since the module can’t be read due to uart being disabled, but it can definitely be done.