X-CTU modem configuration failed


I tried to update my Xbee (XB24-BWIT-004) on my USB-dev board with the X-CTU tool. But there were some communication problems on the USB-bus when configurating the Xbee.
And now I can’t restore the Xbee to it’s old configuration. Always the “Info-popup” shows up and tells me to press the reset button on the board.

Is there anything, that I can do, to restore the Xbee?


The results you’re seeing might be dependant on the type of firmware you programmed on the modem in the first place.

For instance, if an “API” type ZNet 2.5 firmware is programmed on the modem, once its programmed you need to go over to XCTU’s PC Settings tab and check the “Enable API” box to talk to the modem any further.

Another example is that if Router Sensor, Router End Device Analog IO, or Router End Device Digital IO are programmed on the modem, the firmware disables the UART for operation with the corresponding Adapter, so configuration from that point on can only be done over-the-air from XCTU or a ConnectPort X gateway that the radio is associated to.

All that aside, radios do occasionally go into a bad state when being programmed, but re-programming them again with firmware usually brings them back. If not, give Tech Support a call :wink:

The “Enable API” box was the hint I needed. :slight_smile:

I’m having the same problem. However, I believe mine started when I flashed one of my XBee modules with Znet 2.5 Router/End Device Analog IO. I didn’t realize that would shutdown the UART and now I’m having a lot of trouble trying to configure it remotely from my other module. The association LED is blinking twice per second. I flashed Znet 2.5 Coordinator API on my other module and tried using X-CTU’s Remote Configuration. When I click Discover though, no devices show up. Is there some way I can figure out what the settings are on my other module so I can reconfigure it wirelessly? Or is there some other way to reenable the UART so I can reflash it?


Actually, I’ve made some progress. I can now access the other XBee via the X-CTU remote configuration pane, but I can’t figure out how to re-enable the UART since I can’t reflash it remotely.

There is no way to enable the UART when AIO/DIO/Router Sensor firmware is loaded on a module, since the UART needs to be disabled for that module’s use with the AIO/DIO/Router Sensor adapter the firmware was intended for. All module configuration must be done over the air once either of these types of firmware is loaded.

If you need UART/serial access functionality on your module, I’d recommend ZNet 2.5 Router/End Device AT firmware.

Strangely enough, I tried flashing the firmware again and it worked perfectly. I think the trick may have been the “Always update firmware” checkbox. Just in case someone else has this problem, the settings that worked were:

Baud: 9600
Flow Control: None
Data Bits: 8
Parity: None
Stop Bits: 1

Enable API: unchecked
No baud change: unchecked

Always update firmware: checked
Modem: XB24-B

Then click “Write” and press the reset button when prompted. On the SparkFun XBee Explorer, you can add a simple momentary switch between ground and pin 6 (labeled RST on my board) to use as a reset button.

Glad to see you got this going. Thanks for posting the resolution up here as I’d requested in your Support case :wink: