Unknow Modem type problem..and API enable

i run some test by sending and receiving data from XCTU to a standalone MCU-xbee, and it is successful. then suddenly
the Xbee at the XCTU stop working, i try reading it but it says unable to connect. then i tried checking the enable api at PC-setting, then it was able to read trough test/query button and the result shows:

Communication with modem…OK
Modem type=Name unknown(ID=429496724891940)
Modem firmware version=

also i tried restore button and result to:(API enable)
resetting AT Commands…
Programmed Non-AT Settable parameters
Restore Defaults…complete

then when i write result shows:(API enable)
Getting modem type…OK
programming modem…Lost communication with modem
write parameters…failed

it cannot connect when its not on API enable, and also on the restore button sometimes the Update Summary keeps popping, and cant close it.

please suggest some ways to solve the problem, i think i the non-volatile memory is corrupted,and then unable to enter command mode, i also tried “Always update firmware”
i uses a series 2, with ZB firmware(not pro)

problem solve!!!thanks to DIGI


I have the same problem with serie 1:

I test the solution with RS232 but it doesn’t work !

Getting modem type…OK
Programming modem…Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Lost communication with modem
Write Parameters…Failed

thanks for response

If possible please post what you had to do to correct your problem. Others have encounterd the same problem and will also help other individuals in the future.

i think i was in programming mode, then the module was disconnected(the case), then the non-volatile firmware was corrupted.

one solution that was suggested by digi, is that. unplug the power from your RS232 board, set your XCTU to the right settings, set the firmware to default, then write the firmware(POWER UNPLUG source would be the RS232), then the XCTU will response, with some info. then press reset button, plug the power, then let go of the reset button, then the info will disappear and hopefully it will program the xbee…(did many trials before it was completely program)

and also if info occur on the programming part, just reset the xbee. i hope it is clear.

Thanks for the response and this is a good reference for others.

I seem to be having the same problem. I attempted to flash my Xbee2 OEM module with the ZNET 2.5 ROUTER/END DEVICE ANALOG I/O. It seemed to go fine, bet after resetting and trying to identify the device with xctu (with all the possible api settings) all I get as a response is the same error: Communication OK, Name unknown id=429496724800.
I tried to do what you said, with all the plugging and unplugging, but I use a ftdi usb to serial module, and I was not sure where to connect/disconnect the power from. Any help would be much appreciated.

i think you will have some problem on that :smiley:
if you have serial port, try building a circuit to connect your xbee module using an inverter directly to your PC.

oh i forgot…add some reset button

It is possible when using the USB board. You just have to go about it in a different manner.

  1. Take the module out of the interface board.
  2. Connect the interface board to the computer.
  3. Open X-CTU
  4. Go to “Modem Configuration”
  5. Put a check in the “Always update firmware” box
  6. Select proper modem from drop down menu,
  7. Select proper function set and firmware version
    from drop down menus.
  8. Click on the “Write” button. After a few seconds of
    trying to read the modem, you will get an Info box
    that says Action Needed. At this point, CAREFULLY
    insert the module into the interface board.
  9. You may get the info box again a short while after,
    just use the reset button on the interface board.

This should get you back up and running.

Ok, after building a few different serial circuits I still cannot get the module to start talking.
I never get the window that says to restart the module, X-ctu just gives up and says it lost communication with the modem.
So unless there is some way to clear the flash or a factory reset, I think it is done for. Thanks for your your help.

Thanks for the reply. I followed your well written steps, and everything was going great until step 9.
Instead of writing new firmware or something, X-ctu informs me that that it detected a baud rate change and that communication was lost.
I tried the same procedure with all the possible rates, but none worked. I even tried some of the more common parity and flow control settings.
I’m worried that if I keep doing this I am going to bend some pins.

Gracias Rocker1446 …desde Paraguay…funcionó perfecto luego de realizar los 9 pasos!!!


This solved my problem. I had to do it a couple of times but it worked great.

Try sending +++ to the module in the terminal window at 9600 baud 8-n-1 and see if it will respond with OK. If it does send ATRE to restore the module. I have better luck restoring the module this way than with the restore button in X-CTU.

if you have same problem…try building the circuit…it will just use a inverter…then follow the instruction.
i did that for many times.

So, ok a lot of time has passed, but I managed to get mine working again! What the problem was, was that I had ‘use api mode’ checked in the configuration. With this unchecked, the modem programmed by just forcing an install of xb24-zb router api firmware.