X-CTU with XBee Pro 2SB

I’m trying to get X-CTU to communicate with this modules and not having much luck. When I tell X-CTU to Teat/Query the modem, I get back:

Communication with modem..OK
Modem type = Name unknown (ID = 303650)
Modem firmware version = 2270

If I enable API, the response is:

Communication with modem..OK
Modem type = Name unknown (ID = 42949672481982713797)
Modem firmware version = 

That’s it.

What am I missing here? It’s not recognizing the modem as far as I can tell.


Your XBee module is programmed in AT mode, Not in API mode. If you reprogramm it in API mode then you can also get Firmware version for API mode. At that time if API is disabled then by clicking Test/Query button, it will show thw message…“Unable to communicate with the modem”. So, take care while Test/Query. and also do the proper Baud settings. And also take care of rather API mode is ON or AT mode is ON.

These are brand new modules, I haven’t done anything with them yet. I’m just trying to communicate with, and get information from them. So when I Test/Query, either in AT or API mode, I receive the response I posted in my previous message.

When I go to the Modem Configurator and try to Read, X-CTU tells me:

The modem configuration file was not found. Would you like to check the web site for updates? (Recommended)

to which I say Yes.

After a bit of waiting, it comes back and says

Modem configuration file not found after update.

When I try to download new versions (web), it tells me no updates found.
So how do I know what Modem to pick from the drop down list? There doesn’t seem to be a list anywhere that explains what the various options under Modem really are, which Modem they pertain to, or anything else.

Update: I manually downloaded the latest version information from Digi’s website (XBP24-ZB_2970_S2B) and installed it. Now at least when I try to Test/Query the modem, it gives me the correct information, or at least I think it does:

Communication with modem..OK
Modem type = XBP24BZ7
Modem firmware version = 2270

Going into Modem Configuration and trying to Read however, still tells me

The modem configuration file was not found. Would you like to check the web site for updates? (Recommended)

After letting it check the web site, another dialog box comes up and says

Modem configuration file not found after update.

So the configurator still can’t figure out what this module is.

Figured it out. I foolishly assumed that the X-CTU software that I downloaded from this site (version actually had all the information on the various radios, till I noticed its release date being March 2008, three years ago. That prompted me to believe it can’t possibly have all the information for the new modems. So hunting for firmwares, I downloaded the most recent one for my specific radio (from the product support page) and what do you know, it works now.

Again, I assumed the Download new versions … button actually did that. How wrong I was.

Everything is working now, the Test/Query returns correct information, and the Read inside of the Modem Configuration also works and I’m seeing the options I’m expecting to see.

many thanks for writing your “first steps” with XCTU and modules.
I have exact the same problems with XCTU and S2C module.
You solution (find the newest XCTU) works well.

Best regards

Unfortunately works NOT.

X-CTU - S2C SMT - “sharing violation…”


  • PC with XP-Prof and laptop w. Vista P.
  • On both installed X-CTU
  • DIGI HW: XBee ZB SMT Module Dev. Kit (USB)

I try:
X-CTU -> “Test/Query” button:

Communication with modem OK
Modem type = Name unknown (ID=4294 ...etc
Modem firmware version ATVR

Serial Number = ATSH

Looks OK (but name unknown?)
Now “Terminal” window. After type +++ modem answered OK

And now “Modem Configuration”
Button “Read”.
And after approx. 30sec. "A sharing violation occurred while accessing C: … xcite\010C_02.mxi

Two different computers with different OS, different, brand new SMT modules and exact the same error on both.

What’s wrong? Perhaps I’ve overseen something?

Very Zigbee newbe

Go to your modem’s product page and download the new firmware for it. Unzip the contents of the file in %SYSTEM DRIVE%\Program Files\Digi\XCTU\update\ then relaunch X-CTU and try to Test/Query your modem again.


Modem type: unknown [ID = 4294967229-1778315478]
Modem firmware version = ATVR
Serial Number - the same as written on the chip.

USB driver - FTDI from

X-CTU, vers. (may 2010)

(manually reinstalled)

No one of my four usb adapter with S2C module on board answered correctly (modem type). And this make no difference: PC with XT or laptop with Vista.

Grateful for any tips

Problem solved!

The communication problem was caused by the closed “loopback” jumper.

For all newbies: in normally operation P8 has to be opened!