Xbee Series 2 module and X-CTU

Is the Xbee series 2 module compatible with X-CTU (latest version 5.4.1).
Also if it is compatible, can u tell me where i am going wrong.
When i test/query it says unable to connect to modem. Then when i check the enable API box, it says communication with modem ok but says name unknown and does not give me a firmware version.
Also when i try to read it says failed to enter command mode, unable to read version (ATVR) and read parameters…failed.
My baud rate settings are correct .
Also on the terminal window i am getting some gibberish

They are compatible. I would make sure you exit and restart XCTU, then set the baud rate, API (etc) before trying to talk to XBee. Also try 9600 since that is Xbee default.

This is a common annoyance with XCTU - if you get a popup with a huge hex string as the type or name, it means it really didn’t talk.

I generally ignore the test/query unless just going to the modem config tab and asking to READ results in a pop-up saying unknown firmware.

Worstcase, just offlow the bootloader steps to reflash th unit. Yes, is overkill, but fast and less frustrating:

My baud rate is set correctly. However i am not able to type anything on the terminal window as the gibberish doesnt stop. Thus i cant reflash the unit.
Also wen i read , on the command line i get the following error
Failed to enter command mode
Unable to read Version (ATVR)
Read parameters…Failed.


Series 2 modules will support only Zigbee and ZNet. If you enable API, you will need to select API under Function Set(for ex. ZIGBEE COORDINATOR API). Then try to read the parametrs. Still if you get the same error, select the proper Modem and Function set, click on “Show Defaults” then try to write the parameters.
Hope this helps!



In API mode - which is binary - you will see gibberish at the terminal window even at the correct baud rate.

Sounds like your network is too active. If remote ZigBee are sending data to the one you are trying to talk to, of course XCTU will be confused because the responses it sees will NOT match the requests being sent.

Make sure you power down any other nodes linked to your XBee.

I tried whatever u suggested Kavya. When i try to write it tell me connection with modem lost, write parameters…failed.
The only good news is that when i started X-CTU this morning, the terminal window was blank (finally). But still when i tried the bootloader technique, there was no response.
What do i do ??

Also on the terminal window when I type +++ to test the zigbee I get no response.

how about the circuit?

try to match the circuit with the document shown in this site.

click on schematic, it will pop up a pdf file. open. do it. try to open the x-ctu again. hope it helps.


Which firmware (function set) had you loaded previously on the XBee S2 module? If firmware for DIO adapter or AIO adapter is loaded, then it won’t communicate with X-CTU through UART. Are you able to communicate with the module over the air using different Xbee S2 module? If yes, then the best way is to perform over the air firmware upgrade to normal firmwares which points to function set as Coordinator api/at or Router api/at or End Device api/at. Over the air firmware upgrade can be done either through X-CTU or through ConnectPort Gateway e.g. (ConnectPort X4, ConnectPort X5, or ConnectPort X2) with Zigbee.

Sorry for bad English. I had the same problem with module Xbee PRO S2B (XBP24BZ7 v218C).
Let’s try the steps:

  1. Go to page terminal window on X-CTU (ver.
  2. Power on Configurator Board XBee-Pro OFF, then ON.
  3. Press “Enter”, - you will see “MENU”.
  4. Press “B” - set “Bypass mode”.
  5. Go to page “PC settings” window on X-CTU.
  6. Try “Test/Query”. It must work.

That is all. In my case I got all information.

Hi, The technique you are mentioning only works with Xbee ZB S2B probrammable varients only. It does not work with XBee ZB S2 modules

According to the Digi site, the latest version of X-CTU is as opposed to the 5.4.1 that you report. Did you mean to say If so, you might like to upgrade X-CTU and try again.

I have used the arduino board but I connected additionally the DTR and CTS to FT232 and reset to ground, when I need reset during programing, I contains it to GND. it’s works with this solution http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash
I unblock communication to all my xbee-S1/S2
my models:

If the AIO DIO adapter or adapter firmware load, it will not communicate with the X - CTU’s UART. In the air, you can use different XBee S2 module and the module communicate it?