XBee Series 2.5 and API


I used X-CTU to burn XB24-B ZIGBEE COORDINATOR API (V1120) on XBee 2mW Series 2.5. The burning stopped and after that X-CTU could not connect to the XBee chip again.

Any idea what the problem might be?

Note: burning XB24-B ZIGBEE COORDINATOR AT didn’t cause any problems.



The issue you are referring to is a result of the specific firmware files not supporting AT commands directly. When using the API code, all data going in and out of the radios UART must be in API format. To resolve the issue, you will need to enable the API option in the X-CTU software’s PC settings tab.

What do you mean by “the burning stopped”?

If you go to the PC Settings tab in XCTU and check the box for “Enable API”, then hit the “Test/Query” button on that page, do you get a Modem Type and Firmware Version returned to you?

Also, why are you using 1x20 firmware? This firmware has been improved with later versions.

Thanks a lot mvut, it can connect to it now but for some reason can’t read nor write to it.

I mean while burning some error popped (Unable to communicate with modem).

I get Modem Type unknown, and firmware version blank! The Modem Type and Firmware Version were known before using API.

When I run update it returns “No updates found.”

This is the error given when trying to read:

Failed to enter command mode
Unable to read Version (ATVR)
Read parameters…Failed.


Message was edited by: nsn


It sounds as though either the radio is set to a different baud rate. To resolve the issue, I would recommend using the Restore option on the Modem Configuration tab with the API box enabled on the PC settings tab.

I did that, still doesn’t read nor write!


It is starting to sound like you installed a version of the firmware which the UART is disabled (IE Analog or Digital IO adapter). To resolve it, you will most likely need to re-load the radios firmware with the radio powered off. (That is start the firmware re-flash with the power off. Then power it on when the action required box comes up while holding the reset switch.)

I’m using the XBee Explorer USB from SparkFun, it doesn’t have a reset button.
Anyways, if I write anything in the terminal the tx LED blinks!

Please I’m using the same module and found the same problem. As a matter of fact, I’m using the XBee Explorer USB too.
Is there any solution to re-load the firmware?