Bricked Xbee - need HElP!!! (Was running API Router firmware 2321...)

One of my Xbees running API firmware (2321) has stopped responding, and when I run X-CTU and query the modem status, I get a rather cryptic message back that says:

"Communication with modem…OK
Modem type = Name unknown (ID = 4294967281868080)
Modem firmware version = "

And that’s it. When I Read the parameters on the Modem Configuration tab, it always goes to a Modem type of “Unknown”, and at the bottom of X-CTU it displays:

“Failed to enter command mode.
Unable to read Version (ATVR)
Read parameters…Failed.”

It’s in API mode and I know it’s at the correct baud rate (9600) - I’ve even tried multiple combinations of baud rate and API/AT just to check and only the API even looks like it is doing something.

I’ve tried a number of methods found on the web to rewrite the firmware, but I have been completely unsuccessful after 3 hours of trying. The following message always pops up at the bottom after 5-10 seconds:

“Getting modem type…OK
Programming modem…Lost communication with modem
Write Parameters…Failed”

I don’t know what I did to cause this (it worked fine the last time I tested it, and even then I was just trying out the periodic IO sampling functionality) - and this is the first time in 2 years of playing with my Xbees that something like this has happened… HELP! While I can easily go buy a few more 2mW modems to replace this one (and I was planning to do so anyways), I really don’t want to discard this if I can salvage it.


Tried ticking the “Enable API” mode (or un-ticking it), while flashing it, yet?
I had a similar problem before, tried out several ways and finally it was working.

Also tick “No Baud Change”

Hope that helps

No, I have not used the “No Baud Change” checkbox yet, nor checking / unchecking while flashing the firmware. I will try some of these items this evening when I get home - thank you for the ideas! I’ll let you know how they work out.