XStick Bricked?

After using X-CTU to install the XB24-SE profile for a ZIGBEE SE END DEVICE API, with updated firmware, the XStick reset.

Now, when it’s plugged in (and after the reset) an amber light stays solid and it is not responding normally in any tool (including X-CTU).

When I’m on the PC Settings tab and click Test/Query:

Communication with modem. OK
Modem type = Name unknown (ID = 42949672481228512)
Modem firmware version =

On the Modem Configuration screen, when I try to READ the parameters I get:

Failed to enter command mode
Unable to read Version (ATVR)
Read parameters. Failed.

On the Modem Configuration screen, when I try to WRITE parameters:

Getting modem type…OK
Programming modem… Lost communication with modem
Write Parameters…Failed.

I can’t figure out how to get the stick to respond, it feels like it’s bricked or in a state where it’s not letting in commands.

Also, when I use the In-Premise Display / Meter Simulator

I switch the Baud rate to 9600, select COM3 (the correct port), and Open COM Port.

I see at the bottom:

Failure on serial port: COM3 - ddo_get_param: error fetching DDO parameter

Well I fixed it, via button mashing hack.

I brought up X-CTU… unplugged the XStick, started to button mash the write button to hopefully catch the XStick before it gets itself stuck… and plugged it in. Gave it a whirl and it worked.