Modem type =name unknown

When I am connecting x-bee module in x-ctu it is showing like
Modem type =name unknown(id=…some number).

It is very urgent plz help me out


Please reply for this it is important

Hello Naresh,

I assume from your message that you are trying to communicate with your XBee module using the XCTU but you receive that message instead.

I’ll try to give you some tips that may help you:

1 - It is possible that your XBee module is sleeping while you try to establish the communication. I suggest you to press the commissioning or reset button of the device where your XBee module is connected to awake it just before pressing the Test / Query button from the XCTU.
2 - This error can also appear if the baud rate of the serial port is not the same than the XBee module uses. By default it should be 9600, but some devices may override it to a different one. Try to change the baud rate configuration of the XCTU.
3 - My last suggestion is to enable (check) the Enable API option from the XCTU. Maybe your XBee module is not configured in AT mode. In that case you should establish the communication in API mode by checking that option.

I hope it helps.


I would add, this message is generally unimportant. As long as you obtain any response in XCTU, then going to the “Modem Configuration” tab and hitting “Read” will very likely pull all the correct information from the XBee.

(In my experience, this message usually means a baud-rate or API mismatch).

Also, for some reason the Coordinator API firmware seems the most robust, so if I am trying to reflash say an AIO end-device firmware and the firmware update always fails, then first reflashing to API coordinator seems to ‘recover’ the XBee module, allowing me to manually enable “API” mode on the PC Settings tab and then the AIO end-device reflash will succeed.

HI thanks for your reply.

I have tried all the steps what u have mentioned above.But again it is showing the same error.

Any other methods to solve this.

Thanks & Regards

My worstcase recovery solution is to reflash the XBee to the API Coordinator firmware. Then reflash again to the firmware that you want.

For some reason some of the end-device and AT-mode firmwares seem to be settable to modes where they are difficult to reach.

Hi thanks for your reply. I have tried these three methods. I am very new to xbee. I dont know much about this. Why it is showing like this.Any other debugging thechniques for this.Please helpme out from this.If u have any tutorial to configure this plz send me.
Thanks in advance.

The problem is that when you power on your module it connects your port to MC9SO8QE32 and shows main menu:

B-Bypass Mode
F-Update App
V-BL Version
A-App Version

So what you need is enter Bypass mode and communicate directly to EM250.

  1. connect your module to PC (with XBee explorer or Arduino or what you want because only GND, VCC, Din,Dout are required)
  2. Start X-CTU, Go to Terminal tab
  3. type +++ and hit Enter
  4. After menu appears, type B and hit Enter.

Now you can go to General tab and work with your device.
Don’t forget to select correct speed.