My xbee Module is Giving Unknown error

I recently bought two xbee series 2 modules.

Whenever I connect either one of them they give me error

communicating with modem = ok
Modem type=Name unknown(ID = 4294967248309)
Modem firmware version=

I cannot read or write anything because it gives me error of parameter failed.
I tried to reset it but still no use.

I am doing my university final year project, please help me with it.

Hello Saif,

Ensure that you have the latest X-CTU version and download new firmware versions in Modem Configuration / Download New versions…. By the way, XBees Series 2 are ZigBee modules, not WiFi. This or this are more suitable forums. Best regards,

I have the same problem with Saif and I am using Xbee Wifi module. The only difference is that Modem type=Name unknown(ID = 429496722900) seen in my situation. An extra observation is that even when the module is not supplied by a Vcc voltage, and the test is applied again, the result does not change. I see the same com test window.
Please, someone help me, thanks in advance

Best Regards

Reflashing the firmware on the modules with correct Modem, Function set and Version will help.