xbee pro not responding ( factory reset needed )

so let’s start from the beginning

i have 2 modules with usb breakboards (FT232R)…
i want a cable replacement…
the first problem was, i can see the modules with X-CTU but can’t communicate each other…
after a lot research i found the solution!!

connect with 9600 8N1 Xon/Xoff Flow control.

on the 1st module
on the modem configuration press read, select coordinator AT, press restore, PRESS SHOW DEFAULT (that’s the trick), check always update firmware, press write.

on the second module.
on the modem configuration press read, select router/end device AT, press restore, PRESS SHOW DEFAULT, check always update firmware, press write.

that way it seems that i can communicate each other…
the problem is that there is a delay when sending data…

i tried to change the configuration…
i tried to set RO to 0 but nothing…

now the REAL problem!!
while i was updating the firmware it asked me to press reset…
so i press reset wait a little bit and nothing happens… i press the reset a second time and i realize that the upgrade was already started… so i pushed the reset durring firmware update!
now the module is inaccessible… can’t connect with X-CTU not responding to “+++”…
is there way to reset modem to factory settings…?
did i destroy my module…?? :frowning:

oh yes!! lucky me!! :slight_smile:

so the answer for the corrupted software was found!!



select 9600 8N1 (if you try to connect the board IS NOT responding)
go to tab “modem configuration”
select manualy the device (for me its XBP-24B)
select router/end device AT
select version 1241
check update firmware
press write

(a pop up will com saying that you must press reset)

put the device on the board (for me the usb->UART board)

ready!!! :slight_smile:

now for the delay…
on the coordinator write on the DH the value SH value from the other module
repeat for DL and SL.
set RO - packetization timeout to 0

one point…
this device claims to be easy and working out of the box as cable replacement!!
conclusion: i wasted allmost two days searching forums on how to make them work as “out of the box”

yes if you understand the device it’s not so difficult after all but it’s NOT working out of the box!!

users are asking repeatadly how to connect 2 modules as cable replacement, also a lot of users ask how to use ADC and PWM and IO. make to the forum two post and make them “sticky” (always visible first) so everyone with the same question can see directly the correct answer! pls save us some time!!


Message was edited by: -=karpa=-

User648 :

You are now officially one of my heroes!

I tried exactly what you posted – but it didn’t work!
So, I changed the module to “XB24” (which is what I have).
(for whatever reason, entering the correct module type is important :slight_smile:
I discovered a couple of other caveats:
[li]You absolutely MUST leave “Enable API” unchecked (PC Settings)
[/li][li]Apparently, “No baud change” should also be unselected.
[/li][li]After successful flash update, click “Show Defaults” on the Modem Configuration tab.
[/li][li]Then, click “Write” again. That appeared to return the unit to “original factory defaults”

Now, if I can just find what network parameters I was using for the rest of my network, I’ll be all set!

Hi and thankyou for this informative post and the feedback on our support forums. Unfortunately, I can’t make “sticky” posts at this time due to limitations in the forum software. We are looking at replacements however, so hopefully whatever we decide on will support that feature.

it happened something like this, but with the first xbee series. I can’t successfully update the firmware because after I reset the module and I disconnect it, if I connect it again it immediately asks me to reset… and this happens to all the first series modules.
Can you tell my what’s happening?

I’ve seemed to brick my XBee Pro Series 2, and I have been unsuccessful in following these steps. Basically, I selected XB24-B, set my modem to all kinds of settings (9600/19200, 8/N/1, no flow control/HW flow control, Enable API/Disable API). In modem config, I selected ZNET 2.5 Router/End Device AT v1241. I checked “always update firmware” and unplugged my XBee from the Ladyada USB adapter board. When I get the “reset” dialog, I plugged in the XBee module. I waited for about 20 seconds or more, and nothing happened.

Does anyone know what I could be doing wrong? Basically, I bricked my XBee when I tried to do the ZNet 2.5 to ZB firmware update (http://www.digi.com/support/kbase/kbaseresultdetl.jsp?id=3025 ), and although the update was completely successful, I was unable to establish communication with the XBee module afterward.

Unbelievable! I did this process about 40x, and while it didn’t work as expected (dialog would never disappear after hotplugging the xbee module), I eventually left the board in the ladyada adapter and clicked Write. Believe it or not, both modules eventually programmed!

So now what? :slight_smile: Should I leave them alone and get series 1 modules, or try to reprogram them with the ZB firmware again? Has anyone ever gotten that firmware upgrade to work?

Why not just fix the XBee serial interface so this stuff doesn’t happen all the time? As far as I can tell this sort of thing has been a problem in virtually every XBee series ever produced and yet Digi seems unwilling/unable to fix it.