Xbee pro 802.15.4 firmware update fail due to reset not responding.

I am using a xbee pro 802.15.4 on a soliddigi xbee breakout with a umft234xd ftdi and the X-CTU 6.3 on an ubuntu linux and windows 10. When attempting to update firmware (currently stuck on 10e8), I am prompted to reset the xbee. I have attempted to do so in many ways, including short pin 5 to pin 10 and creating a makeshift reset button on a breadboard yet nothing closed the action required window to update firmware.

Help solving this problem is appreciated, thank you.

Optimize USB settings first and then try again:

1 Like

Also make sure that the board you are working with has the DTR and RTS lines connected. If they are not, you will not be able to write firmware to the radio.

Thank you for your response, however optimizing the USB settings didn’t solve the problem, while attempting to update, it still hangs while entering programming mode. Also, RTS is connected to CTS and vise versa. The Xbee itself functions as it should, reading other xbees, therefore I find doing a recovery to be unnecessary. Am I wrong?

If module is operating well, then performing recovery will be unnecessary.

CTS and RTS lines are not required to be interconnected. They should be instead connected to system over USB. These line are present on interface board itself. I doubt if your interface board have these hardware flow control lines. Get one Digi’s XBIB interface board that definitely have these vital lines present.

Sorry, it seems I was unclear, I meant The CTS on the breakout board was connected to the RTS on the USB ftdi mentioned above and the RTS on the xbee breakout was connected to the CTS on the USB ftdi, meant to be a reply for mvut.

Beyond buying a new board, is the current setup really inefficient to update the xbees? It seems I can trigger the reset pin on other applications, yet only when attempting update does it not respond.

Thanks again for your time and patience.

No, it is not enough. As stated on page 13 of the manual located at http://ftp1.digi.com/support/documentation/90000982.pdf, you need DTR as well.

Yes, Digi’s interface board does have these lines connected. You can see this in the schematic located in the knowledge base.

Thank you, connecting DTR to GND got me passed programming mode. Unfortunately a new error is stopping me, Invalid bootloader version.
Again thank you for your answers.

What is the full part number of the module, the modem type, function set and version you are trying to write to the module?

Sorry for the delay. Simply retrying solved the issue, perhaps it was misreading the USB at the time, however the issue hasn’t come up again after a successful update.

Thanks again for all the help.

I’m having the same issue. My module is embedded in a board where TX and RX are attached directly to a processor. I can use serial passthru code on the processor to talk directly to the XBee but there is no DTR/RTS available in this serial implementation. I tried the above tieing DTR to GND and it did not work. Is there any method available with this configuration or should I start looking at OTA options?