XBee cant update firmware


I wanted to setup a simple ptp-communication with the xbee series 2. Therefor I tried to update the router firmware to a coordinator firmware. I selected the newest firmware for the coordinator and clicked on update.
But as it comes to “getting hardware version” it stops and I get an error: could not read the hardware version […] -> bootloader not responding.

Then I tried to recover my module, but I got an error, too:
There is no active bootloader in this module.

How can I fix this problem?

What board are you mounting the XBee module on in order to connect it to the PC with?

I just use an arduino as an USB to UART converter, but with no extra shield. I wrote a program which receives data from PC over USB an sends it out to DIN and DOUT of the xbee module.

But as I’ve read in the data sheet I need to connect two other pins. Does anybody know how to use them correctly to update firmware?

How are you connecting the XBee module to your Arduino? Are you mounting it on an Shield or trying to connect the XBee direct? What is connected to the 2nd XBee module?

You need to connect DTR and RTS to the XBee module with the proper level shifting in order to perform a firmware upgrade.

I connect them direct (via level-shifter).
But the UART on the Arduino has only a receive and a transmit pin, no DTR and RTS pins.
How can I connect them?

That is something you are going to need to ask your Arduino support for help with.

mvut, if I have a FTDI (3.3v) connected to my XBee, how do I have to connect DTR and RTS? DTR(of my xbee) to DSR(of FTDI) and RTS (XBee) with CTS(FTDI) ??? Or something like:

While the following manual is not for this product, page 8 gives you the answer you are looking for. http://ftp1.digi.com/support/documentation/90002210_B.pdf

Thank you mvut, that really works.