How to get past "Could Not Enter Programming Mode" on Series 1 xBee Modules


I’ve spent a great deal of time researching how to resolve this issue and have come up short and would greatly appreciate any feedback you may have.

Each time, I try to update the firmware on my Xbee Series 1 radios, I get a pop up message “ACTION REQUIRED! Reset your radio module” and the update fails.

Here is the sequence:

Getting Device Information [OK]
Entering Programming Mode [Error]
Could not enter programming mode> Could not reset the module.
Error updating the radio firmware.

It can read the radios just fine and I can update settings on the radios just fine, but it will not apply the firmware update.

I’ve installed the FTDI Drivers on Windows 10 and have tested this (same results) on my two different computers using two different versions of xctu and 2 different radio connection types (ftdi cable from adafruit and the arduino board trick). I have 3 different xbee Series 1 radios, 2 I ordered about a year ago and 1 that I ordered a few weeks ago. All 3 produce the exact same result. I am completely baffled.

The process reads the radio with no problem. I have the communication set at 9600,8,N,1,N and have tried both AT and API mode on the radios.

I have installed the FTDI drivers on both computers (once previously on Win 7 computer and once with a fresh XCTU install on Windows 10.

My radios are all marked with XB24-AWI and 2 (older ones) are 001-REVE and the new one is 001-REVH.

I am using the adafruit xbee adapter (P126). I had the two older radios working just fine, but decided that I should update the firmware to the latest version (10EC to 10EF).

I did try resetting the radio (pulling and reinstalling the radio, and setting reset pin to ground) when prompted with the ‘Action Required’ prompt.

I’ve tried to include as much relevant information as possible in hopes that someone may notice what I’m doing wrong and assist.

Thank You!

What configuration utility are you using?

I’m using the most recent version of XCTU.

Ok, I missed that you tried 2 different versions of XCTU. Have you tried all the basic troubleshooting tricks?

Here’s another idea: since you can write to the devices, put one of them in API mode, and use it to discover the other devices as wireless nodes. Then select the wireless devices under the nodes menu and try to update the firmware OTA. If that works then we know that the problem is your interface boards.

2nd idea: try updating in the old version of XCTU, and set the flow control to HARDWARE

By the way you can tell if your devices are sleeping based on the blinking of the association lights, or if the CTS symbol is blinking in the terminal view of XCTU

I’ve tried all of the above. On two different laptops (Windows 7 with an older version of xctu and Windows 10 with the current version of everything). I still get the reset popup. I am using the adafruit xbee adapter. But, I’ve also tried using my UNO as an adapter and I get the same results. I have 2 radios. 1 is older and has firmware EC and the newer one has EF. I am having other issues and I suspect it’s related to the firmware mismatch.

If you haven’t seen these threads yet, they might help:

Thanks. I think that I’ve ready every single thread on this topic. I’ve tried everything and keep getting that same popup. This thread is pervasive and tons of people have this same issue. It would be great if digi would step in and offer some assistance.

I’ve spent hours looking for a fix to this problem. I’ve created a video of what is happening and I hope that someone can help!

I must be doing something very wrong. I’ve tried this with 3 different radios and an uno (Rather than the adapter) and they all product the same error.

Here is the video:

Do you see anything glaring that I am doing wrong here?

Thank You!

I’m actually a tech support engineer in training at Digi, and I’ve been trying to troubleshoot problems here on the forums.

I apologize that I haven’t been able to find a solution for your problem yet, but if you email we will be able to open an official support ticket for you and I’ll have one of my senior colleagues look at it.

I had one of my coworkers take a look at your video, and he looked up the schematics of the hardware that you are using.

He says the main problem is your cable. It’s missing one of the required flow control lines (DTR) for flashing new hardware. We recommend USB Xbee adapters for flashing firmware.

Additionally, if you’re getting a new board, we recommend getting one with a built-in reset button in order to avoid having to manually connect cables.

Thank you for video. Now I now that I`m not alone with this problem)
Are you find solution a problem?

Me too trying use 3 devices, but always this problem.

The following link contains information on the recommended and required pins:

We suggest you use one of the following USB interface boards. They have been tested an approved by Digi:

In Russia these interface boards does not exist. At all.
Im trying to use another boards from China, which exist in shops, but unsuccessfully. What is "Active bootloader"? XCTU cannot connect to "active bootloader" on XB24-AWI-001 (serial 1) and different methods of restarts (pushing button, sending remote AT-command "FR" from another XBee, pulling and inserting of the module in the hand-made devboard) doesnt helping.
This discuss exist on another forum with photos and detailed description of the problem:
But there are nobody know solution of my problems

Please, help me. I have a diploma at the end of Junuary, but I`m stalled on this problem.

Thank you!

You’re getting the “active bootloader” error because you don’t have the required serial lines to flash firmware updates. Please examine my link earlier in this thread regarding recommended and required pins.

How can I determine what pins in DE-9 connector are needed for RTS and DTR?
Pins 1 and 2 from DE-9 connector are used for DOUT & DIN (pins 2 & 3 on XBee)

Thank you!
Is was easy, but I’m wasn`t paying attention when read the datasheet.
RTS connected with pin 16 through galvanic isolation, DTR connected with GND and it working!

I’m not familiar with a DE-9/DB-9 connector that has Rx/Tx on pins 1 and 2. They usually have Rx/Tx on pins 2 and 3:

Yes, you are right. It’s a typo.
RTS is a 7 pin of DE-9 connector, DTR can be connect with GND on XBee module and firmware update is successful.

i am facing the same problem, but am using xbee shield is their any problem or should i buy FTDI board.i have tried all the solutions given here but same message pop up “could not enter programming mood>could not reset the module”