recovery problem


I wonder if one of you could give me a hand:

My module (Xbee s2 XB24-Z7WIT-004) was initially recognised by X-CTU (using macintosh). I was able to read the settings. However, since I tried to upload a new firmware X-CTU cannot read the module anymore.
Recovery mode does not work, although it does start uploading the new firmware but stops after a while and gives this message:

"Could not program the radio module. > EM250 Bootloader v20 b091. upload ebl2. run3. ebl infoBL > "

or somites this turns up:
“Could not program radio module. Error verifying the page written.”

I am a newbie in this field, hope I can get this solved with your help. Thank you.

What are you mounting the XBee module on in order to connect it to your MAC?

Hi there

I am using the Adafruit Xbee Adapter kit ( .
I have solved the problem today. Well, I do not know what exactly the problem was, but I restarted the mac and the XBee too, did several attempts and now the new firmware has been uploaded. I made a coordinator (AT) and also a router (AT) and they recognise each other. Thank you for your input.
p.s. The firmware upload process doesn’t seem to be as smooth as it would be on a PC though. It requires several attempts, but it works eventually.


That is not just because of a Mac but because not all interface boards provide all of the lines required for firmware updates. So what would be an easy process become difficult.