XB24C recovery failure

My two XB24C modules worked perfectly fine yesterday, but when i connected them to my laptop today XCTU couldnt read Hardware and Firmware data.

Then i tried recovering them (XB24C - ZIGBEE TH Reg - 4059) and it said
“– Resetting and entering bootloader… [ERROR]
There is not an active bootloader in the module.”

Can anyone help me please?
Could that be caused by the fact that i changed the mode to API yesterday?

Thxalot for helping in advance

Generally no that would not cause that.

How are you connecting the radios to the PC? What are you connecting them to?

What is the Full part number of the radio in question? It should be something like XBP24CZUIT-004.

The two XBee modules are each on one Arduino Wireless & SD shield (this one: https://www.arduino.cc/en/Main/ArduinoWirelessShield) which are on two Arduino Mega 2560

I connect them via the USB port on the Arduino Mega

The full part number is XB24CZ7WIT-004-revF

The Shield you are using does not allow direct access to the XBee module from the USB port. The USB port goes into the Arduino first and then out. In order for XCTU to access the module, it needs direct control over the XBee. It also needs to have direct access to the DI, DO, RTS and DTR lines.

But i already set them up! They already worked and I successfully sent Hello from the “master” to the “slave” and then I disconnected them from my laptop and the next day XCTU couldn’t read Hardware and Firmware data anymore… It still recognizes them on the defined ports (COM7 and COM12) but I can’t access them anymore.

What do you mean by you can’t access them any more? Are you saying they can’t send and receive or you can’t read their firmware?

When I connect them to my laptop and start XCTU and click on “Discover devices” then it shows the port COM7 or COM12 depending which i connected and then i click “Next”, select all relevant settings and then click “Finish”, then it says “Could not find any device in port COM7 > Error initializing XBee device parameters > Connection timeout. > Could not read Hardware and Firmware Versions.”

But all the settings and connections are the same as when I first set them up and configured them.

As I said, it already worked without any problems and only after I disconnected it there were problems.

Did you enable the SM or Sleep command?

The only two parameters that I changed were the API mode on both and Coordinate mode on one of them. I did not change anything else.
(Btw the approval times are pretty long, is there any other way to discuss that without waiting for the comments to be approved and added?)

No, not in the forum. The forum is customer helping customer only.

The only thing I can think of is a connection between the PC and the xbee on were the issue is. This is where a known good interface board is worth $1000. Simply because you can take the module and place it on a board that is guaranteed to work regardless of the configuration.

Okay so I have to wait everytime i guess…

Hmm but isn’t the official Arduino connection board supposed to provide a flawless connection? That’s why it’s more expensive than a few others available on the internet and that’s why i chose it for my project. I always had good experiences with the official Arduino stuff. That’s the first time that I have problems with it…

But what part of the connection do you think might be the problem? The cable, the Arduino Mega or the connection board?

No, an official board just means that you can connect the XBee to the Arduino and know that it will work that way. Not that you can connect the XBee to the PC.

Can you recommend me any way to connect the XBee to the PC?

Sure, try using a Development board such as the XBIB-U-DEV or Xbee Grove board.

I guess these XB24C modules will now just be forgotten in one of my drawers… SCREW THEM!! :stuck_out_tongue:
Thank you so much for all the help and if there might be any way to PM you pls let me know :slight_smile:

If it was me, I would spend the $20 or so an simply get the Grove board.