XBee flash recovery OK, still won't connect!

Hey guys,

Something weird happened to my new XBee Pro XSC S3B 900. It was happily receiving data, simply plugged into an Adafruit Xbee Adapter (RSSI resistor disconnected) -> FTDI cable -> PC USB.

All of a sudden XTU showed me all these garbage values in all the configuration fields highlighted in yellow, like outside the usual ranges bad garbage. The XBee stopped working and when I tried to reflash firmware using the regular method gave me the following error “the firmware version of the radio module changed” and asked to update the firmware db.

Nothing worked so I disconnected the module, from then on XCTU never detected it, even with the 45min search across all serial options.

The weird thing is - RECOVERY - FLASH FIRMWARE is fine, I short pin 5 to 10 when the dialog pops open about reset, then everything proceeds fine, not a single error in the details section. Result - OK, but XCTU still can’t connect to the module using defaults or search-all.

What can I do at this point? Thanks!

Try using an XBIB-U-DEV board which has all of the required lines for firmware updates instead of a board that doesn’t.