How do I recover from failed firmware upgrade?

XCTU version 6.1.1, XBIB-U-SS rev. D adapter, XB2B-WFUS-001 rev. B module. While trying to update from version 2004 to 2021 I got an “Action Required” dialog box saying “press reset”, so I did. Since then XCTU has
been unable to find the module. I used the “recover” tool several times trying to flash both 2004 and 2021 versions but always get the message “Could not program the radio module.>communication with modem lost.”
The module Rx and Tx lights flash while recover is writing to flash memory but the lights are off during verify.

Are there any other recovery methods to try?


Have you tried the method outlined on the Knowledge base article below?
Recovery procedure for Digi RF products

Thanks for the help.

I downloaded XCTU version 5 to match the instructions in the Recovery Procedures article and it recovered just by
reloading the firmware.

Summary: XCTU version failed the firmware update and did not recover the XB2B-WF-SMT module,
version worked.