Cannot update firmware for XBee-S1 using XCTU 6.5.12

When I try to use XCTU to detect my radio board (on a USB adapter board), I can quickly find it and add it to my list.

When I try to check the configurations of the XBee-S1 board, the software complains about not having the right firmware for it and asks if I want to get it. When I try to do so, it fails.

I’ve check the firewall (both added rules for XCTU and also turning all of it off, too) and there are no VPN on my network (I am its administrator and can confirm this!).

What can be done to fix this so that I can configure my XBee-S1 modules?

Here are images of the XCTU version/about page and what I’ve tried and the results:

Access to the FTP server which was producing the error has been resolved. Note that this may not help in updating the firmware on your old XBee 802.15.4 modules as the firmware version 10EC is very old and out dated. You may have to use the recovery function to update it to a more current version.

1 Like

Ah, good to know!

Yeah, they are old modules I had from 2012 that I just found in a box! Figure I’d give them a run and see which ones still worked well… up to now I have 2 working ones out of 6!

While I was waiting for an answer concerning the firmware package upgrade, I actually ended up using the legacy X-CTU to connect to my older Xbee-S1 running 10EC and updated that software’s firmware libraries with the newest one. This allowed me to change firmware after all!

Do you have a link to information on recovery function?

You can find it in the manual at XCTU User Guide

1 Like