Xbee Series 1 Firmware Update

Have both XB24 and XBP24 802.14.4 modems with V1060 firmware. Can the firmware be upgraded to a later version?

While X-CTU reports the modem type and firmware version correctly, and in ‘Terminal mode’ I am able to enter command mode and interrogate the modem, any attempt in ‘Modem Configuration Mode’ to read the modem fails with a message box stating ‘The modem configuration file was not found. Would you like to check the website for update?’

Attempts to manually select the modem type with any firmware versions (1081 to 10CD) starts off a process but I get…

‘Getting modem type…OK’
‘Programming modem…Lost communication with modem’
‘Write parameters…Failed’

Maybe V1060 is too old perhaps.

If you are using a development board, press the reset button after one of the LEDs go solid for a few seconds. This should do the trick.

Thank you fordcf2000 - but I am not seeing ‘one of the LEDS go solid’ - which one(s) are you referring to?

I am wondering if the modules are too old and are unable to be updated. Version 1060 of the firmware gets no mention in the forum and X-CTU complains of not being able to find a 1060 config when attempting a modem config read.

Could admin offer a few words?

Don’t give up - there are other things to try.

Have a look at this forum topic:

In there you’ll find a more elaborate sequence of steps. See whether that works, and let us know.

Have done as johnf suggested to no avail - and thank you for your input.

Decided to attach my small logic analyzer to the DIN and DOUT signals and here is what I get…

Cmd (Response)
“+++\r” (“OK\r”)
“ATHV\r” (“1809\r”)
“ATVR\r” (“106\r”)
“AT\r” (“OK\r”)
“ATSL\r” (“40084BB2\r”)
“AT%P273C\r” (“ERROR\r”)
“ATFR\r” (“OK\r”)

… the “AT%P273C\r” is a bit odd. The only commands having a ‘P’ as the second letter and also having 4 hex digits for parameters are the “SP” and “DP” commands.

The process is understandably terminated at the error notification but the ‘%’ character emitted by X-CTU is not.

This is getting serious.

  1. Are you using the latest version of X-CTU? Check on the Digi site, and if there’s a later version than you have, download it.

  2. If you can communicate with the module, send ATRE to reset all parameters to their factory defaults, and then ATWR to write them to non-volatile memory.

  3. Try reflashing the module again, and also try this recipe (which was contributed a while back by fordcf2000 if memory serves):

  • If you get an error message when you click the Write button in X-CTU, hold down the reset switch on the development board while you click the Write button again. Keep the reset switch down for another second, then release it.

I think we’ve now dredged up all the recipes that have ever appeared on the forum, so if all that fails it’s time to contact the fine folks at Digi support. If you mention this topic they’ll be able to see what you’ve tried.

I would also recommend using the following sequence to upgrade the radios firmware:

  • Connect the OEM module to an RS232 interface board and the PC leaving the power disconnected
  • Launch the X-CTU
  • On the PC settings tab, select the proper COM port, 9600 baud, 8 data bits No parity and 1 stop bit
  • On the Modem Configuration tab, select the XB24 from the modem type, 802.15.4 for the function set and 10A5 for the firmware version
  • Click on Show defaults and write
  • When the action required box comes up, hold the reset switch in and power on the radio. Then release the reset switch. This should then allow the action required box to close and the install to finish.

I tried musshel’s suggestion first and then johnf’s with the same result as before. To complete the picture I applied my trusty LA to look at a ‘Read’ of the modem where I get…

Cmd (Response)

“+++” (“OK\r”)
“ATCF1\r” (“ERROR\r”)
“ATVR\r” (“106\r”)
“ATHV\r” (“1809\r”)

… so methinks X-CTU (V5.1.4.1, on Win2k desktop) is misbehaving and not at all happy with V1060 modules. The
‘%’ character it sends on the write sequence seems to me to be a bung printf().

As johnf suggests I should now be in contact with Digi support and I would if I could. Can’t get past the login
screen - doesn’t accept my email address/password.

And when requesting my password to be emailed, never a reply is received.

Re the email address and password: try creating a new login for the support request. I think the support database and the forum database are separate entities, so a login/password that works for one will not work for the other.

Have re-entered my original details which got through. Sent of a ‘new case’ and await their response after which I will update this thread.

Many thanks.

Well, yes, sometimes we learn our lessons the hard way.

After I uninstalled old X-CTU, deleted the program folder, rebooted and installed new X-CTU, I got to where I want to be - all my XB24/XBP24 modules are now 10CD.

Previously I had just uninstalled the old, installed the new and carried on. Where I erred was in not deleting the program folder and rebooting.

Thanks to those who showed interest.