Xbee firmware 10CD Can't overwrite other firmware version.

I change old XBee firmware is 10CD version.
I download firmware 10E6 from web to update X-CTU.
And I update firmware to 10E6 version, but it can’t write.

X-CTU status is
“Getting modem type…OK
Programming modem…Lost communication with modem
Write Parameters…Failed”

Then I can’t change firmware to other version.
How can I change firmware?

I also had this problem. I found this worked for me. I am using an XB24 in a Adafruit XBee adapter shield, with FTDI Chip TTL-232R cable.

Connect your USB to TTL cable, or other connection method. Determine the COM port used.

Open X-CTU, select the proper COM port in the ‘PC Settings’ tab.

Then click on the ‘Modem Configuration’ tab.

  1. Put a check in the ‘Always update firmware’ button.

  2. Select your ‘modem’ type (for me- XB24)

  3. The ‘Function Set’ and ‘Version’ were set properly automatically for me (XBEE 802.15.4 and 10E6). Change them if you need to.

  4. Now REMOVE (yes, remove) the XBEE chip from the adapter. Now back on X-CTU , click on the ‘Write’ button. After a short wait, a window will come up saying it was unable to communicate.

  5. Now insert the XBEE chip into the adapter. The window should disappear, and the firmware upgrade begin.

I have had to try this 2 or three times sometimes, but it has worked for me a few times now as I have been learning :slight_smile:

I have seen this method used in an adapter with a ‘reset’ button, which mine does not have. If yours does, you may not have to remove the XBEE chip.

that worked for me too for 2 out of 3 radios. using the reset button on the xbib-u-dev board didn’t help at all.

had to remove the radio then reinsert it to the board. whatever!

at least you helped me save 2 out of 3 radios!


This (unseating the XBee before clicking “write” in X-CTU) worked for me - my XBee Pro was in a Sparkfun Explorer Dogle (USB) plugged directly into my computer’s USB port.

I’d hate to say it… I really LOATH saying this, but try another PC.

I tried this under an XP machine and pulled my hair out, much the same way you have, I am sure. I tried it a dozen times a dozen ways. I tried a million other things. I tried it all…

…then I tried from my 64bit vista ultimate CAD station, and it worked without any trickery…

…which is a shock, considering nothing else on my 64bit Vista machine works without some strange magic.

There is an issue in the 10CD code that requires you to downgrade to 10A5 first before you can upgrade to the 10E6. Try that and you will find that it will work 99% of the time.

Thank’s for every post.
Maybe I have bad luck, I try every way that all of you recommend me.
It’s still doesn’t work. :cry:

Thank’s again :slight_smile:

There is an issue in the 10CD code that requires you to downgrade to 10A5 first before you can upgrade to the 10E6. Try that and you will find that it will work 99% of the time.

This did the trick for me!

i am having the same issue. i have tried all the above solutions and none of them worked. i’ll paste in a post i made on another forum here to provide details:

i ordered 5 xbee XB24 (series 1) modules, and all are working well except one.

4 out of the 5 shipped with firmware 10E6 (latest). 1 shipped with firmware 10CD, and this is the one with the problem… i can’t update the firmware on this unit, and i feel i’ve tried almost everything.

this is the error message X-CTU gnerates:

Getting modem type…OK
Programming modem…Lost communication with modem
Write Parameters…Failed

here are the details:

  • i am using a dechipped arduino duemilanove to interface to the xbee via usb
  • X-CTU queries and reads the xbee config successfully
  • i am able to write individual config parameters to the module (CH, SH, NI, etc)
  • tried the removing the module from the socket trick that works for some people (remove module, let update fail, replace module, reset board, upgrade is forced)
  • tried starting update with reset button depressed, waiting for failure, releasing
  • tried downgrading to 10A5 before upgrading to 10E6 . downgrade failed with same error

basically nothing i do will let me update the firmware. the fact that this one module shipped with this old firmware while all the others in my shipment had the current version is suspicious. seems like a factory defect that was passed on to the consumer, no?

You will need to downgrade to 10Ax first and then you can upgrade to 10E6.

Hello, I know this is an old thread but hopefully this information is helpful to someone with this issue. The manual re-flashing using the reset button or unseating the chip works but is difficult to get it to work sometimes - especially if you are trying to walk someone over the phone thru the process.

BUT, thankfully I discovered something new today. The new version of X-CTU seems to be able to change the firmware on a locked 10CD Xbee (I’m using 1st generation Xbee Pro modules). It didn’t require holding reset or reseating the chip, it went thru fine (it did say “flashing at 38400 baud” which was different than what I had it set to initially).

So if you’re reading this, try the new X-CTU! (I am on version 6.3.0)