upgrade firmware impossible

With some of my Xbees I cannot upgrade the firmware. I get the following error message:
“Getting modem type…OK
Programming modem…Lost communication with modem
Write Parameters…Failed”.
I run XP and the X-CTU version is
Are there some older modules which firmware cannot be changed?
I get the impression that they are stuck with the 1084 firmware version!

There aren’t any modules that can’t be reprogrammed, but sometimes it can be a bit tricky.

If you check out the sticky threads at the top of the 802.15.4 forum, you’ll find the FAQ. Question 11 addresses this topic - have you tried those suggestions?

If they don’t work, please ask again. Or, if they do work, let us know - that kind of feedback is useful.

I have tried all your tricks, none worked with 2 of my Xbees (the oldest ones). I can read the settings alright (and modify them) but I CANNOT upgrade the firmware. On the back below the mention XB24-ACI it is written:
“001 revB 2008-02-25”
Thanks for your help!

Ok, you’ve tried all the tricks that have been collected.

Don’t give up yet!

I think it’s reasonable at this stage to put in a support request to the fine folks at Digi. Tell them what the problem is, and tell them what you’ve tried. I’ll bet they’ll come up with an answer.

When they do, please post here what the successful answer was. I’ll add it to the FAQ, so that others may be helped in the future.

Take a look at this wiki page I created - http://www.digi.com/wiki/developer/index.php/Bootloader_to_force_XBee_reflash

I too was having issues reflashing Xbee (ZigBee) and this is an effective but unfortunate work-around. You’ll find the XBee DIO and AIO adapter firmware especially tricky.

If this force of the bootloader doesn’t work, then your XBee or dev board might be damaged.

I hope this same proceedure works with the freescale XBee - I don’t use them (the 802.15.4 or DigiMesh). The ZigBee are based on Ember chips.